This is a migrated thread and some comments may be shown as answers.

Tabs not showing up

0 Answers 41 Views
TabStrip
This is a migrated thread and some comments may be shown as answers.
E
Top achievements
Rank 1
E asked on 28 Oct 2008, 01:06 PM
Hi,
I derive my control from the tab control and when i try to add tabs to it, they do not show up...

 

this.Tabs.Clear ( );

 

 

foreach ( nsMy.TabEnum eTab

 

 

in System.Enum.GetValues ( typeof ( nsMy.TabEnum ) ) )

 

{

 

string sTab = this.GetTabResourceString ( eTab );

 

Telerik.WebControls.

Tab oTab

 

=

new Telerik.WebControls.Tab ( sTab );

 

 

this.Tabs.Add ( oTab );

 

oTab.Visible =

true;

 

oTab.Width =

this.Width;

 

oTab.Height =

this.Height;

 

}

The page renders with no tabs as follows...

 

 

<div id="SiteNavigationTabs" class="tabstrip RadTabStrip_Default " style="height: 52px;

 

width: 996px;">

 

 

 

 

 

<!-- 3.6.6 -->

 

 

 

 

 

 

<script type="text/javascript" src="/Holstein.Business.Web.Ui.Y2k9/WebResource.axd?d=w3G4nS8o0t2zayUSiMlufsMDJVIituibxCiGv_d-TD3cAdYf9bXCOF1_zwdfZ4jaqvgpkZdnJwg4y0NOygwBmKIPWeOaLYlMSTe-X9Sq7w-WyjLI9gJO5hreQg5Dy0Ya0&amp;t=633518902860000000"></script>

 

 

 

 

 

 

<span id="SiteNavigationTabsStyleSheetHolder" style="display: none;"></span>

 

 

 

 

 

 

<div class="levelwrap level1">

 

 

 

 

 

 

<ul>

 

 

 

 

 

 

</ul>

 

 

 

 

 

 

</div>

 

 

 

 

 

 

<input type="hidden" id="SiteNavigationTabs_Hidden" name="SiteNavigationTabs" /><script

 

 

 

 

 

 

type="text/javascript">window["SiteNavigationTabs"] = new RadTabStrip("SiteNavigationTabs");window["SiteNavigationTabs"].Initialize({"Enabled":true},{});</script>

 

 

 

 

 

 

</div>

 


No answers yet. Maybe you can help?

Tags
TabStrip
Asked by
E
Top achievements
Rank 1
Share this question
or