Size changes after 1st mouseover

3 posts, 1 answers
  1. John Davis
    John Davis avatar
    119 posts
    Member since:
    Apr 2007

    Posted 13 May 2008 Link to this post

    On the first mouseover the tooltip displays as desired.  On all mouseovers after the first one, the position changes (not a problem) and the width becomes smaller (a problem).  For example, instead of seeing
    Units: Each
    I see
    Units:
    Each

    ---------------------------

    <rad:RadToolTip ID="RadToolTip1" runat="server" TargetControlID="ImageButton1"  Sticky="true"  ShowCallout="false">
          </rad:RadToolTip>

    protected override void OnPreRender(EventArgs e)
            {

                    Label L= new Label();
                    L.Text = "Initial Capacity (ACAP):";
                    if (UserContext.Session.SCSInfo.IsIt.UnlimitedACAPwhenBalanced_YN)
                    { L.Text += " unlimited";}
                    else
                    { L.Text += UserContext.Session.SCSInfo.ACAPwhenBalanced.ToString(); }

                    if (UserContext.Session.SCSInfo.IsIt.UnlimitedACAPwhenBalanced_YN)
                    { L.Text += " (Use all)"; }

                    RadToolTip1.Controls.Add(L);

                    RadToolTip1.Controls.Add(new System.Web.UI.HtmlControls.HtmlGenericControl("BR"));

                    Label L2 = new Label();
                    L2.Text = "Units: " + UserContext.Session.SCSInfo.ACAPUnitOfMeasureName;
                    RadToolTip1.Controls.Add(L2);

  2. Georgi Tunev
    Admin
    Georgi Tunev avatar
    7207 posts

    Posted 14 May 2008 Link to this post

    Hi John,

    I tried to reproduce the problem locally with the code that you provided but to no avail - everything worked as expected and the tooltip's size is not changed.

    Please open a support ticket and send us a small sample project where this problem can be reproduced. Just make sure that the project can be run and attach it to the ticket - we will check it right away and do our best to help.


    Sincerely yours,
    Georgi Tunev
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. Answer
    John Davis
    John Davis avatar
    119 posts
    Member since:
    Apr 2007

    Posted 16 May 2008 Link to this post

    Georgi

    Thank you for checking.  This problem is gone after upgrading to SP1.

    John
Back to Top