This is a migrated thread and some comments may be shown as answers.

Scheduler Bug with Month View & Time Zones

1 Answer 27 Views
Scheduler
This is a migrated thread and some comments may be shown as answers.
Paul
Top achievements
Rank 1
Paul asked on 01 Jul 2008, 04:11 PM
Just happened to notice that if you are viewing the month view and click on today, the month of July is displayed properly (happens to be July 1st when I write this). However, when using TimeZone, the month shows up as June!

This can be seen in the online example.

This works (click Month then Today):  http://www.telerik.com/DEMOS/ASPNET/Prometheus/Scheduler/Examples/BlackPearl/DefaultCS.aspx

This doesn't (same selections): http://www.telerik.com/DEMOS/ASPNET/Prometheus/Scheduler/Examples/TimeZones/DefaultCS.aspx

It seems that if the tail end of the previous month is displayed on the calendar, then that's the month that gets labeled, not the current month.

Should be an easy fix hopefully....

1 Answer, 1 is accepted

Sort by
0
Dimitar Milushev
Telerik team
answered on 02 Jul 2008, 02:25 PM
Hello Paul,

Indeed, when using a negative TimeZoneOffset and the first day of the month is selected, the header displays the previous month. We will make sure to fix this in the next version of RadScheduler.

Thank you for taking the time to report this.

Regards,
Dimitar Milushev
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
Tags
Scheduler
Asked by
Paul
Top achievements
Rank 1
Answers by
Dimitar Milushev
Telerik team
Share this question
or