RadTabStrip and RadMultiPage

4 posts, 0 answers
  1. Prashanthi
    Prashanthi avatar
    7 posts
    Member since:
    Jan 2012

    Posted 13 Feb 2012 Link to this post

    I have a asp.net page with a RadGrid and RadTabStrip on it.
    On RadGrid_ItemSelected of the the RadGrid , the RadTabStrip selected index is set to 0 & RadMultiPage selected index is also set to 0.

    RadTabStrip1.SelectedIndex = 0;

     

    RadMultiPage1.SelectedIndex = 0;

    RadPageView1.Selected = true;

     

    The first tab is getting selected, but the controls in RadPageView1 are not loaded.
    Instead the controls on RadPageView2 (the other tab) are showing up.



  2. Dimitar Terziev
    Admin
    Dimitar Terziev avatar
    1268 posts

    Posted 15 Feb 2012 Link to this post

    Hello,

    Could you share the declaration of your RadTabStrip and RadMultiPage so I could inspect it.

    Regards,
    Dimitar Terziev
    the Telerik team
    Sharpen your .NET Ninja skills! Attend Q1 webinar week and get a chance to win a license! Book your seat now >>
  3. Prashanthi
    Prashanthi avatar
    7 posts
    Member since:
    Jan 2012

    Posted 15 Feb 2012 Link to this post

    Here is my declaration. Thanks.

     

    <tr>
         <td>
             <telerik:RadTabStrip ID="RadTabStrip1" runat="server" MultiPageID="RadMultiPage1"
                 SelectedIndex="0" CssClass="tabStrip">
                 <Tabs>
                     <telerik:RadTab Text="Assign Permissions">
                     </telerik:RadTab>
                     <telerik:RadTab Text="Add New" Selected="True">
                     </telerik:RadTab>
                 </Tabs>
             </telerik:RadTabStrip>
         </td>
     </tr>
     <tr>
         <td>
             <telerik:RadMultiPage ID="RadMultiPage1" CssClass="MultiPage" runat="server" SelectedIndex="0">
                 <telerik:RadPageView ID="RadPageView1" runat="server" BorderWidth="1px">
                     <UserDetail:Detail ID="UserDetail" runat="server" />
                 </telerik:RadPageView>
                 <telerik:RadPageView ID="RadPageView2" runat="server" BorderWidth="1px">
                     <UserNew:New ID="UserNew" runat="server" />
                 </telerik:RadPageView>
             </telerik:RadMultiPage>
         </td>
     </tr>

  4. Dimitar Terziev
    Admin
    Dimitar Terziev avatar
    1268 posts

    Posted 20 Feb 2012 Link to this post

    Hello,

    I've inspected the declaration of your controls and it looks right. What seems strange to me is the fact that both controls has SelectedIndex="0" , but the second tab has its Selected property set to True.

    In order to further troubleshoot this issue, try to provide the implementation of the user controls where the RadGrid resides.

    All the best,
    Dimitar Terziev
    the Telerik team
    Sharpen your .NET Ninja skills! Attend Q1 webinar week and get a chance to win a license! Book your seat now >>
Back to Top