RadScheduler appointment drag and drop not working on Chrome when page is scrolled

3 posts, 1 answers
  1. Bobi
    Bobi avatar
    5 posts
    Member since:
    Jan 2012

    Posted 17 Oct 2017 Link to this post

    When the page is reloaded with initial scroll, the appointments that are not visible and some who are at the top rows cannot be moved ( all other at the lower part are working fine). It depends of the page scroll, if i scroll down even more and hit refresh, more of the upper appointments will be disabled for moving.
    This problem start to occur after chrome version 61. On Mozilla Firefox and IE it works fine. 

    I tried with 2017.1.330 and 2017.3.913 version of telerik and the problem still persist.

    This is how i use RadScheduler
    <telerik:RadScheduler ID="DayViewScheduler" runat="server"
                                    Height="960" ShowFooter="False" OverflowBehavior="Expand"
                                    DataKeyField="Id" HoursPanelTimeFormat="hh:mm tt"
                                    DataSubjectField="Subject" DataStartField="StartDate" ShowAllDayRow="False" ShowViewTabs="False"
                                    DataEndField="EndDate" TimeLabelRowSpan="1" CustomAttributeNames="ServiceInstanceId,ServiceTypeValue,Details,ReservationColor,BlinkIndicator"
                                    OnNavigationComplete="DayViewScheduler_NavigationComplete" OnDataBound="DayViewScheduler_DataBound"
                                    OnAppointmentDataBound="DayViewScheduler_AppointmentDataBound" OnFormCreating="DayViewScheduler_FormCreating"
                                    OnAppointmentDelete="DayViewScheduler_AppointmentDelete" OnAppointmentInsert="DayViewScheduler_AppointmentInsert"
                                    OnAppointmentUpdate="DayViewScheduler_AppointmentUpdate" OnClientAppointmentResizeStart="OnClientAppointmentResizeStart"
                                    OnAppointmentCreated="DayViewScheduler_AppointmentCreated"
                                    OnClientAppointmentMoveEnd="onAppointmentMoveEnd" OnClientAppointmentResizing="onAppointmentResizing"
                                    OnClientAppointmentResizeEnd="onAppointmentResizeEnd" EditFormDateFormat="dd/MM/yyyy"
                                    EditFormTimeFormat="HH:mm" meta:resourcekey="DayViewSchedulerResource2"  Width="960px">
                                    <MonthView UserSelectable="False" />
                                    <WeekView UserSelectable="False" />
                                    <TimelineView UserSelectable="False" />
                                    <ExportSettings>
                                        <Pdf PageBottomMargin="1in" PageLeftMargin="1in" PageRightMargin="1in" PageTopMargin="1in" />
                                    </ExportSettings>
                                    <AdvancedForm Modal="True" />
                                    <AppointmentTemplate>
                                        <div class="personPopupTrigger" rel='<%#Eval("Id")%>' url='<%=ResolveUrl("~") %>'>
                                            <%# FormatText(Eval("Subject")) %>
                                            <dx:ASPxImage ID="ASPxImage1" ImageUrl="~/CSS/images/alertAppointment.gif" runat="server"
                                                Visible='<%#Convert.ToBoolean(Eval("BlinkIndicator"))%>'>
                                            </dx:ASPxImage>
                                        </div>
                                    </AppointmentTemplate>
                                </telerik:RadScheduler>
  2. Answer
    Peter Milchev
    Admin
    Peter Milchev avatar
    503 posts

    Posted 18 Oct 2017 Link to this post

    Hello Bobi,


    Version 61 of the Google Chrome introduces some breaking changes in the behavior of the browser which may lead to such issues when the browser is scrolled. 

    More information can be found here: https://www.telerik.com/forums/appointment-is-invalid-and-cannot-read-property-errors-for-scheduler-in-chrome-61.

    Would you please check if there are any JavaScript errors in the browser console and if the suggested solution resolves them? 

    Regards,
    Peter Milchev
    Progress Telerik
    Try our brand new, jQuery-free Angular components built from ground-up which deliver the business app essential building blocks - a grid component, data visualization (charts) and form elements.
  3. Bobi
    Bobi avatar
    5 posts
    Member since:
    Jan 2012

    Posted 20 Oct 2017 in reply to Peter Milchev Link to this post

    Hi Peter,

    i assumed that the problem was in Google Chrome browser. There aren't any errors in the console, but the problem, is solved by the script that i found in the link you give me. Thanks for this quick answer

Back to Top