This is a migrated thread and some comments may be shown as answers.

RadRotator inside a RadMultiPage

6 Answers 50 Views
Rotator
This is a migrated thread and some comments may be shown as answers.
Telmo Silva
Top achievements
Rank 1
Telmo Silva asked on 11 Aug 2008, 12:24 PM
Hi Guys,

Q2.2008 release rocks!  Good job getting everything over to the AJAX release.  I am having some issues however with the RadRotator inside a MultiPage.

Basically I have 2 different RadRotators each on its own RadPageView inside one RadMultiPage.

Unless the RadPageView is defaulted (using SelectedIndex property on RadMultiPage) the RadRotator does not display.  In other words the RadRotator is only displayed if its on the page that is drawn on PageLoad.

I hope the above makes sense.  Is there an issue with what I am trying to do or is there a workaround?

Thanks in advance,

6 Answers, 1 is accepted

Sort by
0
Lini
Telerik team
answered on 12 Aug 2008, 01:35 PM
Hi,

It seems that the rotator cannot correctly calculate its size on the client if it is initially hidden. We will fix this bug in the next RadControls release.

Regards,
Lini
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
Telmo Silva
Top achievements
Rank 1
answered on 12 Aug 2008, 02:59 PM
Thanks for the quick response.  Is there a workaround?  I have defined the Height of the RadRotator at design time, could I re-set the height using JS or elsewhere?  I have a client demonstration in 3 weeks, so waiting for the next release is not an option for me.

Any help would be greatly appreciated,
Telmo
0
Accepted
Lini
Telerik team
answered on 13 Aug 2008, 10:13 AM
Hi Telmo,

Unfortunately, I don't think that there is a workaround available. I suggest that you open a formal support ticket so we can send you a custom hotfix build, where this problem is fixed. This way you will not need to wait until the service pack release.

Sincerely yours,
Lini
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
Ken Milhous
Top achievements
Rank 2
answered on 27 Aug 2008, 08:23 PM
Is there a fix for this yet? im having the same issue.
0
Tervel
Telerik team
answered on 28 Aug 2008, 06:12 AM
Hi Ken,

The latest RadControls release (Q2 S1) which was released two days ago addresses the problem. Please, download it and give it a try. In case there is a problem, let us know.

Greetings,
Tervel
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
Georgi Tunev
Telerik team
answered on 28 Aug 2008, 11:06 AM
Hi Ken,

Please make sure that you are using the latest version of the control (SP1 that was released on 26th of August) and you will not experience this problem anymore.


Best wishes,
Georgi Tunev
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Tags
Rotator
Asked by
Telmo Silva
Top achievements
Rank 1
Answers by
Lini
Telerik team
Telmo Silva
Top achievements
Rank 1
Ken Milhous
Top achievements
Rank 2
Tervel
Telerik team
Georgi Tunev
Telerik team
Share this question
or