radprompt and WMP

4 posts, 0 answers
  1. Frank
    Frank avatar
    10 posts
    Member since:
    Nov 2008

    Posted 08 Apr 2009 Link to this post

    I have a problem. I have a page that has multiple windows media players displaying videos on it. I have a button on the page that allows the user to send the videos to a library. I am using radprompt control to allow the user to enter a description of the video set. However, when the prompt displays, it shows up behind the videos. I have tried several settings on the RadWindowManager but none seem to help the problem.

    How can I make the radprompt show up on top of the videos playing on the page?

    Here is the html of one of the WMPs:

    <object id="Player5" classid="CLSID:6BF52A52-394A-11d3-B153-00C04F79FAA6" type="x-oleobject" width="210" height="150">
    <param name="Name" value="Player5" />
    <param name="URL" value="mms://127.0.0.1/test" />
    <param name="SendPlayStateChangeEvents" value="true" />
    <param name="autoStart"" value="true" />
    <param name="uiMode"" value="none" />
    <param name="WindowlessVideo" value="false"/>
    <param name="ShowAudioControls"" value="false"/>
    </object>

    P.S. Setting WindowlessVideo to true is not an option.
  2. Georgi Tunev
    Admin
    Georgi Tunev avatar
    7207 posts

    Posted 09 Apr 2009 Link to this post

    Hi Frank,

    Try setting the "wmode" parameter to "transparent" for the object that you are inserting.


    Kind regards,
    Georgi Tunev
    the Telerik team

    Check out Telerik Trainer , the state of the art learning tool for Telerik products.
  3. Frank
    Frank avatar
    10 posts
    Member since:
    Nov 2008

    Posted 09 Apr 2009 Link to this post

    I added <param name="wmode" value="transparent" /> to the windows media player parameters but it had no effect...I assume wmp is ignoring it.
  4. Georgi Tunev
    Admin
    Georgi Tunev avatar
    7207 posts

    Posted 10 Apr 2009 Link to this post

    Hello Frank,

    First of all - please excuse me for the omission. I missed to notice that you are using windows media player which is actually the reason why wmode is not working for your case. The windows media player is an activeX control and the browser will always display it above all other elements on the page. Unfortunately there is no solution for this problem. The only suggestion in such scenario is to use a flash player to show the movies - it behaves as expected in all major browsers and the wmode parameter controls its appearance.



    Regards,
    Georgi Tunev
    the Telerik team

    Check out Telerik Trainer , the state of the art learning tool for Telerik products.
Back to Top