RadEditor is causing problems with the postback function

3 posts, 0 answers
  1. darrel
    darrel avatar
    12 posts
    Member since:
    Nov 2007

    Posted 04 Jan 2008 Link to this post

    We're RadEditor lite on our MOSS install at the moment.

    I've discovered an issue with any master page I create that implements the RadEditor control for the page content.

    In IE 6 (doesn't happen in IE 7 nor Firefox), if I go to a page to edit it, and then go to MODIFY SHARED WEB PART on any instance of the RadEditor, and then click any NON-postback link (such a link in the breadcrumbs), I get a pop up error window in IE stating:

    Line: 88
    Char: 9
    Error: The download of the specified resource has failed
    Code: 0
    URL: [the page I'm on]

    In the generated source, line 88 falls in the default postback script:

    <SCRIPT type=text/javascript fixed_bound="true">
    var theForm = document.forms['aspnetForm'];
    if (!theForm) {
        theForm = document.aspnetForm;
    function __doPostBack(eventTarget, eventArgument) {
        if (!theForm.onsubmit || (theForm.onsubmit() != false)) {
            theForm.__EVENTTARGET.value = eventTarget;
            theForm.__EVENTARGUMENT.value = eventArgument;
    // -->

    This is an issue for me as I am dynamically creating a link on the editable page that it a javascript toggle. What happens is that the first time they click this, they get the error, ahve to hit OK and then it works fine.

    I've completely wiped out my own javascript and worked from a clean copy of a masterpage and page layout template and still get this error as soon as I go to edit a RadEditor instance.

    Any ideas as to what might be causing this?

  2. Lini
    Lini avatar
    2144 posts

    Posted 07 Jan 2008 Link to this post


    I tried the web part in IE 6 on Windows XP SP2 and did not see the error. Check if there is a JavaScript error when the page loads - it might be responsible for the problem.

    A number of people have reported problems with IE 6 in the past. The problems usually caused by compressed web resources (WebResource.axd and ScriptResource.axd from ASP.NET 2.0 and ASP.NET Ajax Extensions). IE6 has problems downloading these resources. Try getting the latest critical updates for IE from Windows Update and see if that helps.

    If there is no error during page load and you have the latest from Windows Update, then please send us a sample master/content page so we can test them locally.

    I also did a simple google search about this error but the results were too general to be of any use. If possible, use a HTTP debugging proxy (for example - Fiddler) to check exactly what requests are made by IE and which one fails.

    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. darrel
    darrel avatar
    12 posts
    Member since:
    Nov 2007

    Posted 07 Jan 2008 Link to this post

    Fiddler looks great! Alas, it apparently breaks my connection to our MOSS server, as I can't log in nor navigate our site with Fiddler runing.

    That said, APOLGIES! I wrongfully accused RadEditor. After some more digging, I can now replicate the issue sans RadEditor itself using just the default.aspx masterpage without any modification.

    As far as I can tell, this is either an IE or a MOSS issue...and not a Telerik issue. Sorry for the false alarm!
Back to Top