RADEditor in SharePoint 2010 treating HTML tags as text

2 posts, 0 answers
  1. Andrew van Renen
    Andrew van Renen avatar
    1 posts
    Member since:
    Sep 2009

    Posted 28 Feb 2012 Link to this post

    Hi there

    We are using RADEditor (6.2) with SharePoint 2010 with a slightly modified version of the News site.  The page has 3 fields ('Title' [single line of text], 'Page Description' [multiple lines of text] and 'Page Content' [publishing html]).

    The problem we have is that the 'Page Description' field is rendered with the HTML treated as part of the text (so the the user is shown the raw HTML).  However, when in edit mode, the field renders correctly.  The other fields on the page behave as expected in both modes.

    Could someone tell me what is going on here?

    Thanks,
    AndrewvR

  2. Rumen
    Admin
    Rumen avatar
    14351 posts

    Posted 01 Mar 2012 Link to this post

    Hello,

    Check the content type of the Page Description and Page Content fields and make sure that the Page Description content type is the same as of the Page Content content type.

    If you have any custom code for the presentation field, review it and see whether it does not display the raw text instead of the saved HTML content.

    All the best,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
Back to Top