"RadEditor - please enable JavaScript to use the rich text editor" message in RadEditor

6 posts, 0 answers
  1. Sumit
    Sumit avatar
    17 posts
    Member since:
    Jun 2010

    Posted 03 Jan 2012 Link to this post

    Hi,

    I'm experiencing a weird issue in radeditor (v2010.2.826.35) in my aspx pages. Following message appears just under the editor in preview mode:
    RadEditor - please enable JavaScript to use the rich text editor

    I checked and find that some <noscript> tag gets added to the editor which displays this message.

    I tried removing it, but failed.

    Can you please suggest on why this is happening and how to get rid of it?


    Sumit
     
  2. Richard
    Richard avatar
    479 posts
    Member since:
    Nov 2011

    Posted 03 Jan 2012 Link to this post

    Sumit:

    Are you displaying your RadEditor with FireFox when you get this message? See the FireFox: RadEditor - please enable JavaScript to use the rich text editor thread for a similar reported issue. It provides some insights on the internal use of <NOSCRIPT> in the Editor.

    Regards,
  3. Sumit
    Sumit avatar
    17 posts
    Member since:
    Jun 2010

    Posted 04 Jan 2012 Link to this post

    Hi,

    Thanks for the reply. This appears in IE (7,8,9).
  4. Svetlina Anati
    Admin
    Svetlina Anati avatar
    2795 posts

    Posted 04 Jan 2012 Link to this post

    Hi Sumit,

     This message is shown when you have disabled javascript through a browser settings. What you should do is to check in the IEDevToolBar tool Disable menu whether you have a tick next to Script option. If so, you should remove the tick and reload the page - this will fix the problem.

    In the common case this will not affect your users because by default script is enabled for browsers so your users will not have to make an extra step.

    For your convenience I attached corresponding screenshots - with disabled script and the problem and with enabled script and things working fine.

    Regards,
    Svetlina Anati
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now
  5. Sumit
    Sumit avatar
    17 posts
    Member since:
    Jun 2010

    Posted 05 Jan 2012 Link to this post

    HI Svetlina,

    This doesn't happen at my end. Please see the attached screen-shot
  6. Rumen
    Admin
    Rumen avatar
    14469 posts

    Posted 05 Jan 2012 Link to this post

    Hi,

    Could you please switch the Browser mode and Document Mode dropdowns to Internet Explorer 9 as shown in this screenshot?

    Please, also test the Default Demo of RadEditor and let us know whether the problem is reproducible.


    All the best,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now
Back to Top