Rad Editor and Rad Window on same page not working

5 posts, 0 answers
  1. Vishnu Vardhan Reddy
    Vishnu Vardhan Reddy avatar
    20 posts
    Member since:
    Oct 2011

    Posted 27 Jan 2012 Link to this post

    Hello,

     I am using Ajax model pop up ,rad window and rad editor on the same page.Now,my telerik edior and telerik rad window are not working.
    Previously,I dont have rad window on my page where I am using rad Editor.That time It worked fine.Now,as per our requirements,I newly added rad window to it and I am using that as a model pop up on my page.Now,the problem is on my head,becuase of this,rad ediotor behaving viard ,it has been disabled,I am unable to click any of the buttons on the rad edior and I am unable to type into it.In other pages it is working fine.

    I googled it.I am helpless,I dont find any solutions to my problem.

    I am grateful to you people.If you respond back ASAP.


    Thank you.

  2. Marin Bratanov
    Admin
    Marin Bratanov avatar
    5465 posts

    Posted 27 Jan 2012 Link to this post

    Hi,

    Please examine the following help article that treats a common cause for such behavior: RadEditor Does Not Work in RadWindow. If this is your case the fix is a very simple JavaScript function that you need to attach to the RadWindow.


    Greetings,
    Marin
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now
  3. Vishnu Vardhan Reddy
    Vishnu Vardhan Reddy avatar
    20 posts
    Member since:
    Oct 2011

    Posted 30 Jan 2012 Link to this post

    Hello Marin ,

    Thanks for the replay.

    I think,I confused you people.I am not using any rad editor on the rad window.I am using these two controls on the same page but not Rad Editor on the Rad window.I am using wizard steps,in the first step I am showing rad Editor to show some html content as template.(Which is not working It has been disabled) and I am using Rad window in the next wizard step to show a grid in the Rad window.I clearly verified.As I am new to rad controls,I dnt know what is going on.Please help me.


    Thanks
    Development Team,
    Intelex Systems.
  4. Rumen
    Admin
    Rumen avatar
    14351 posts

    Posted 30 Jan 2012 Link to this post

    Hello,

    Try to enable RadEditor with the information provided in this forum sticky note: Incorrect rendering of RadEditor when shown with AJAX in initially hidden parent. If the problem still persists isolate it in a sample working project and send it for examination via a support ticket.

    All the best,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now
  5. Vishnu Vardhan Reddy
    Vishnu Vardhan Reddy avatar
    20 posts
    Member since:
    Oct 2011

    Posted 31 Jan 2012 Link to this post

    Hello Rumen,

     Thanks for the Replay.It helped me a lot. Finally, I am out the problem.Thanks Man.



    Cheers!
     
Back to Top