Rad Calendar Dates Disbaled on Load

2 posts, 0 answers
  1. soumi
    soumi avatar
    5 posts
    Member since:
    Oct 2006

    Posted 14 May 2008 Link to this post

     

    Hi,
     
     The scenario is I have a Rad Calendar inside a Rad Grid. The first time I fired the page on my local, I had the RadCalendar undefined javascript error, but when I refreshed it it never ever came back again. Same thing I deployed on our test server and I get this error every time I load the page first time. Only first time,  not after that. This has also caused my Rad Grid to throw the same error of RadGridNamespace is undefined, while I have Rad Grids in almost 10 other pages where I am not getting this error. I have tried the following ways found on Telerik forums:

      1) Set the UseEmbeddedScripts="false" so that the scripts from the Rad Controls folder at the root of the application will be used instead of loading from the browser (which actually does not make sense here because the control works fine after the first time that means it is able to access the WebResource.axd files).

    2) Checked if “Check that file exists” checkbox in the IIS for .axd type files for this application is unchecked. It is unchecked.

    3) Cleared the cache to make sure it’s not because of Cache.

    4) I have also specifically provided the skin name in the RadCalendar along with UseEmbeddedScripts=”false” condition.

    5) The version of the DLL’s in the bin and the scripts in the RadControl folder are the same.

    I am using the Q12007 SP2 version of the Telerik Rad Controls. Is there something I am missing?

    So in short the Rad Calendar and the Rad Grid (on this specific page only) are not picking up the webresources the first time the page is loaded, after that they are fine. And even if I have forced it to use the scripts from the RadControls folder, by setting the UseEmbeddedScripts=”false” its not making any difference.

    This has been eating a lot of my time. Please do advice as to what else can be done.

    Thank You,

    Soumya

  2. Iana Tsolova
    Admin
    Iana Tsolova avatar
    3388 posts

    Posted 17 May 2008 Link to this post

    Hello Soumi,

    All the steps you performed is just what should be done in case like yours. However, as it seems this does not help, I suggest you open a formal support ticket and send a sample project, in which the problem can be reproduced, to debug it locally and find a solution for you. If this is not possible, send us the problematic page or paste your code in this thread and we will do our best to help you out.

    Best regards,
    Iana
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
Back to Top