Problem with RadEditorMOSS and WSS 3.0

4 posts, 0 answers
  1. Remi
    Remi avatar
    6 posts
    Member since:
    Apr 2008

    Posted 06 Jun 2008 Link to this post


    We use WSS 3.0 SP1 only not MOSS.
    We have successfully installed and used RadEditor for MOSS 4.5.1 for couple months. We then tried to install RadEditor for MOSS 5.0.1 following precisely the installation instructions (ASP.NET AJAX Extensions 1.0 then the RadEditor Solution).
    We had no problem using "Telerik RadEditor for MOSS" Web Part, but we could not make it work in List Items.
    We made sure to log as an administrator when we enabled the Features, so that the TelerikRadEditor.ascx gets copied to 12\TEMPLATE\CONTROLTEMPLATES folder as explained here, and we checked:  it was successfully copied.
    However, we still had WSS default Rich text Editor.

    The Sharepoint Log file gave me a clue : "Load control template file /_controltemplates/TelerikRadEditor.ascx failed: Could not load file or assembly 'Microsoft.SharePoint.Publishing, Version=, Culture=neutral, PublicKeyToken=71e9bce111e9429c' or one of its dependencies. The system cannot find the file specified. "

    'Microsoft.SharePoint.Publishing' is not a WSS Assembly, so TelerikRadEditor.ascx, used in List Items cannot work as is on WSS!
    I manually edited the \TEMPLATE\CONTROLTEMPLATES TelerikRadEditor.ascx to remove the reference to this assembly and removed :

    <%@ Register TagPrefix="CMS" Assembly="Microsoft.SharePoint.Publishing,... 

    and removed the control which was using the CMS reference : 

    <div id="originalEditorContainer" runat="server">  
      <CMS:HtmlEditor ID="RichHtmlField" runat="server" /> 

    and the control now works on List Items.
    Is this a safe change? Thanks Telerik for your prompt reply.



  2. George
    George avatar
    859 posts

    Posted 09 Jun 2008 Link to this post

    Hi Remi,

    Thank you for the provided information.

    I logged the problem in our ToDo list and we will do our best to research and fix it as soon as possible.

    Your points were updated.

    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. Bryan Brannon
    Bryan Brannon avatar
    65 posts
    Member since:
    Aug 2012

    Posted 25 Jun 2008 Link to this post

    Is there an ETA on the new version related to this issue?  I followed the instructions to the letter without success, then found this article which seems to apply to my issue.  however, after removing the above lines from the .acsx file, it still doesn't work. 
  4. Lini
    Lini avatar
    2144 posts

    Posted 26 Jun 2008 Link to this post


    We have released a new version of the RadEditor for MOSS (v5.10) which fixes this problem. The publishing html template is now separate from the rich text template so you should have no problems using the list editor in WSS v3.0 web sites. If you still have problems with the latest build, please notify us so we can investigate further.

    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
Back to Top