This is a migrated thread and some comments may be shown as answers.

Problem with EmptyMessage & Load On Demand

6 Answers 77 Views
ComboBox
This is a migrated thread and some comments may be shown as answers.
Axe
Top achievements
Rank 1
Axe asked on 09 Sep 2008, 04:24 AM
Hi

I was playing around with lastest demo and noticed when I use the EmptyMessage property with load on demand from this page http://demos.telerik.com/aspnet/prometheus/ComboBox/Examples/PopulatingWithData/AutoCompleteSql/DefaultCS.aspx the OnItemsRequested doesn't fire until second character is typed in. If you type 1 character hit backspace and type another character it will fire. If I remove EmptyMessage property all works as expected.
Just thought I would let you know. I'm running the trial dll's version 2008.2.723.35.
Of course there could be somthing wrong on my end but all I did was run the sample and added EmptyMessage property.

Regards

6 Answers, 1 is accepted

Sort by
0
Yana
Telerik team
answered on 10 Sep 2008, 07:09 AM
Hi,

I tested our demo of RadComboBox with Load On Demand and EmptyMessage set and wasn't able to reproduce the described issue - OnItemsRequested is fired when the user types one character. Please check the attached movie.

Greetings,
Yana
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
mO
Top achievements
Rank 1
answered on 04 Nov 2008, 01:40 AM
Hi,
I face exactly the same problem in my application. Ditto repro steps as described by Axe.
I saw the movie, but the problem exist for my code.
Let me know if there is a solution for this.
Thanks
mO
0
Veselin Vasilev
Telerik team
answered on 04 Nov 2008, 09:54 AM
Hi mO,

We have not experienced such problems in our tests. Please open a new support ticket and attached a sample project demonstrating the issue.

Thanks

Regards,
Veselin Vasilev
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
Brett
Top achievements
Rank 1
answered on 12 Nov 2008, 03:21 PM
Has there been any progress on this?  The issue seems to only appear if you programmatically set the EmptyMessage property in your code behind.  If you have multiple combo boxes setting just one of the EmptyMessage properties breaks all the other controls.

Version: 2008.3.1016.35
0
mO
Top achievements
Rank 1
answered on 12 Nov 2008, 05:14 PM
I have submitted a support ticket and the team is working on a hotfix for this issue. I'll update the thread once I have a fix.
0
Simon
Telerik team
answered on 13 Nov 2008, 01:22 PM
Hi all,

Please use the attached trial hotfix build where the issue is resolved.

If you need the dev version, please open a support ticket and request it there.

Thank you.

Regards,
Simon
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Tags
ComboBox
Asked by
Axe
Top achievements
Rank 1
Answers by
Yana
Telerik team
mO
Top achievements
Rank 1
Veselin Vasilev
Telerik team
Brett
Top achievements
Rank 1
Simon
Telerik team
Share this question
or