Problem with align buttons

4 posts, 1 answers
  1. Marcin
    Marcin avatar
    192 posts
    Member since:
    Jan 2011

    Posted 02 Nov 2011 Link to this post

    I have simple editor on my page. This editor contains align buttons toolbar (center, right, justify).
    I've set newline mode to paragraphs which I can see in html editor. I have set CSSFiles for editor set to empty css. I have option StripFormattingOptions="NoneSupressCleanMessage" to prevent firefox crash with big copy paste.

    My problem is that align buttons not working, pressing them do not change anything. They look like cannot be pressed. Nothing is happening during pressing. On html preview nothing is changing.

    What am I missing?

    PS.
    1. I'm working under firefox 7
    2. I notice that clicking allign buttons is changing aligment of font toolbar, font comboboxes. I notice the same issue on demo. Sometimes when clicking alignemnt buttons it is changing aligmnet of source code below not one in editor.
  2. Answer
    Rumen
    Admin
    Rumen avatar
    14351 posts

    Posted 02 Nov 2011 Link to this post

    Hi Marcin,

    I have good news that the problem is fixed in the Q3 2011 beta release of RadControls for ASP.NET AJAX and will not exist in the official Q3 2011 release.
    You can test the live beta demos at http://demos.telerik.com/aspnet-ajax-beta/editor/examples/default/defaultcs.aspx and confirm that the problem is solved.

    Regards,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now
  3. Chris
    Chris avatar
    10 posts
    Member since:
    Jan 2012

    Posted 25 Jan 2012 Link to this post

    Rumen,

    I am actually seeing a similar problem, and I am seeing it with the live site demo you have listed.

    If you click in the first paragraph (starting with "RadEditor is not simply an HTML1 Editor") and immediately click any of the alignment buttons, nothing will happen. In other places it seems to work, though.

    I believe this to be not completely fixed at this point in time.

    Thanks,
    Chris
  4. Rumen
    Admin
    Rumen avatar
    14351 posts

    Posted 30 Jan 2012 Link to this post

    Hi Chris,

    This a browser related issue, which occurs with more complex content. You can reproduce the same problem with the same content in the Mozilla's rich text editor demo. The browser's Justify commands could not handle such content and for this reason the formatting is not applied to the selected content.

    Since the beta is scheduled for this week, we will be unable to solve this serious problem, but we will do our best to fix it for the official release.

    Greetings,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now
Back to Top