This is a migrated thread and some comments may be shown as answers.

.NET 3.5 SP.1 problem

5 Answers 66 Views
Grid
This is a migrated thread and some comments may be shown as answers.
Nick
Top achievements
Rank 2
Nick asked on 14 Aug 2008, 01:30 PM
Installed it on my server last night (no other changes) and now any grid that has an aggregate="sum" in it triggers a 'specific cast is invalid'.

8(

5 Answers, 1 is accepted

Sort by
0
Nick
Top achievements
Rank 2
answered on 14 Aug 2008, 01:38 PM
Some further testing - Count type dosen't crash.  Avg crashes.  Max doesn't crash.  I've tested other columns, same result.  These are all integer columns.
Removing dataformat doesn't help.  Added an aggregate data format, didn't help.
0
Vlad
Telerik team
answered on 14 Aug 2008, 02:00 PM
Hello Nicholas,

Can you please set EnableLinqExpressions to false and let me know about the result?

Greetings,
Vlad
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
Nick
Top achievements
Rank 2
answered on 14 Aug 2008, 02:05 PM
Bingo! Thanks for the awesomely fast reply!
0
Jeff
Top achievements
Rank 2
answered on 26 Aug 2008, 06:50 PM
Vlad,
Setting EnableLinqExpressions to false works but is there going to be a fix for it?
We removed all of the aggregates while we were testing to find the problem and will use this work around and put them all back in.  I was just curious if there was a fix?  I have installed and tested version 2008.2.826.35 and that doesn't fix it.
Thank you very much,
Jeff Sager
0
Vlad
Telerik team
answered on 27 Aug 2008, 07:51 AM
Hi Jeff,

We will do our best to provide fix for this issue before Q3.

All the best,
Vlad
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Tags
Grid
Asked by
Nick
Top achievements
Rank 2
Answers by
Nick
Top achievements
Rank 2
Vlad
Telerik team
Jeff
Top achievements
Rank 2
Share this question
or