Lost all my Telerik Tools

2 posts, 0 answers
  1. neebs
    neebs avatar
    106 posts
    Member since:
    Apr 2007

    Posted 03 Feb 2012 Link to this post

    Somewhere along the line, all my telerik tools have disappeared from the toolbox. I am running Visual Studio 2010 Version 10.0.40219.1 SP1Rel and Telerik WebUI VSExtensions 2011.03.1350.0. If I go to the add toolbox and select "Select Items", none of the Telerik.Web namespaces appear. I've tried using the ToolBox Configurator with no luck. I read many of the similar posts on this topic and attempted to follow some of the advice given. So I uninstalled the latest Telerik RadControls for ASP.NET AJAX (Q3 2011 i think) and attempted to reinstall it. Here is where it gets weird. I had earlier cleared out my download folder to save space and when I ran the install on the latest RadControls, it wanted all of my msi files from earlier versions. So the install failed. 

    Now I do not see the latest Telerik RadControls in Programs and Features Control Panel, but telerik thinks that everything is up to date. I still cannot get my tools back. I'm currently re-downloading all the earlier versions so I have the msi's on hand. Any idea on what's happening here and what I can do to get everything back in order?

    Thanks, Steve
  2. Chavdar Dimitrov
    Chavdar Dimitrov avatar
    104 posts

    Posted 08 Feb 2012 Link to this post

    Hello Steve,

    Thank you for contacting us.

    If you succeed to install the latest version of RadControls for ASP.NET AJAX you should get the Toolbox items and the Telerik Visual Studio extensions. I guess that you have a broken/not properly uninstalled older version of the suite and this is why you are prompted for a previous version.

    It will be very helpful if you send us the log file from the installation, so that we can examine the problem in detail. You can generate the full log file using the following steps: 
    1. Open the Command Prompt;
    2. Navigate to the folder where the msi installation package;
    3. Run the following command: msiexec /i [InstallerFileName] /limev Installation.log;
    4. Run the installation and wait for it to fail;
    5. Log file will be generated in the same location as the msi package;

    Still, if you have the MSI you are prompted for, you can try to navigate to it and let the installation continue.

    Looking forward to your reply.

    Best regards,
    the Telerik team
    Sharpen your .NET Ninja skills! Attend Q1 webinar week and get a chance to win a license! Book your seat now >>
Back to Top