This is a migrated thread and some comments may be shown as answers.

LoadingPanel Only Appears Once

2 Answers 39 Views
Grid
This is a migrated thread and some comments may be shown as answers.
Chase Florell
Top achievements
Rank 1
Chase Florell asked on 07 Nov 2008, 11:06 PM
I am using the RadGrid and the RadAjaxManager to Ajaxify my Grid.  I have paging enabled and when I click from Page 1 to Page 2, the loading panel appears properly.  However the problem comes when I click back to Page 1 or forward to Page 3 etc.  The LoadingPanel no longer appears....

any thought?
<telerik:RadAjaxManager ID="RadAjaxManager1" runat="server" EnableAJAX="true" UpdatePanelsRenderMode="Inline" DefaultLoadingPanelID="RadAjaxLoadingPanel1">  
    <AjaxSettings> 
        <telerik:AjaxSetting AjaxControlID="RadGrid1">  
            <UpdatedControls> 
                <telerik:AjaxUpdatedControl ControlID="RadGrid1" /> 
            </UpdatedControls> 
        </telerik:AjaxSetting> 
    </AjaxSettings> 
</telerik:RadAjaxManager> 
<telerik:RadAjaxLoadingPanel ID="RadAjaxLoadingPanel1" runat="server" Transparency="20" BackColor="White">  
    <img alt="Loading..." src='<%= RadAjaxLoadingPanel.GetWebResourceUrl(Page, "Telerik.Web.UI.Skins.Default.Ajax.loading.gif") %>' style="border: 0px; position:relative; top:50%;" /> 
</telerik:RadAjaxLoadingPanel> 
<telerik:RadWindowManager ID="RadWindowManager1" runat="server" Skin="Telerik" /> 

2 Answers, 1 is accepted

Sort by
0
Sacha Rice
Top achievements
Rank 1
answered on 08 Nov 2008, 12:18 AM
Try adding

LoadingPanelID="RadAjaxLoadingPanel1"

to this line

                <telerik:AjaxUpdatedControl ControlID="RadGrid1" LoadingPanelID="RadAjaxLoadingPanel1" /> 
0
Chase Florell
Top achievements
Rank 1
answered on 08 Nov 2008, 12:19 AM
Yeah that was my initial way of doing it... no luck there either.
Tags
Grid
Asked by
Chase Florell
Top achievements
Rank 1
Answers by
Sacha Rice
Top achievements
Rank 1
Chase Florell
Top achievements
Rank 1
Share this question
or