Image replaced with   in Firefox

2 posts, 0 answers
  1. SteadyRain Developer
    SteadyRain Developer avatar
    16 posts
    Member since:
    Apr 2010

    Posted 18 Feb 2011 Link to this post

    I believe I've discovered a fairly severe error in the Rad Editor.  I discovered this while using DNN 5.6.1, but the Rad Editor demo on this website behaves the same way.  This bug appears in Firefox, but not in Internet Explorer.

    Set the editor to use <p> paragraph tags instead of <br> break tags, by setting the following:
    <property name="NewLineBr">false</property>

    Within the editor, add an image to the blank content area.
    The image should display correctly.  Press the Enter key to create a new paragraph after the image, and the image should "disappear."

    If you inspect the source code, you should notice that the image tag has been replaced by the &nbsp;

    Again, this bug seems to only be in Firefox.
  2. Rumen
    Admin
    Rumen avatar
    13843 posts

    Posted 23 Feb 2011 Link to this post

    Hello SteadyRain,

    Thank you for contacting us.

    We are familiar with this weird problem and it is logged for fixing in our bug tracking system. I escalated the problem and if possible we will fix it for the upcoming Q1 2011 release.

    Best regards,
    Rumen
    the Telerik team
    Registration for Q1 2011 What’s New Webinar Week is now open. Mark your calendar for the week starting March 21st and book your seat for a walk through all the exciting stuff we ship with the new release!
Back to Top