Image alignment Issue on Firefox

2 posts, 0 answers
  1. Jose
    Jose avatar
    13 posts
    Member since:
    Oct 2007

    Posted 13 Feb 2012 Link to this post

    Hi,

    I am having a problem when we add an image to the editor and then use the alignment feature. I am using Firefox 10.

    Steps:

    1) Go to telerik demo website. http://demos.telerik.com/aspnet-ajax/editor/examples/default/defaultcs.aspx
    2) Delete everthing inside the content.
    3) Add an image (I used 276x250-asp.net-featured_thumb_thumb_thumb_thumb.gif).
    4) Click on the image (when you see the 8 points around the image, used to resize the image).
    5) Click the align center button (It will center the image as expected, you will notice that the 8 buttons mark will not be show, probably because it lost focus).
    6) Click the image again (when you see the 8 points around the image, used to resize the image).
    7) Click align Left button.

    You will see that the image if was moved to the left as expected, but the 8 buttons around the image still on the center.

    Is there anything we can do about this?

    Thanks in Advance.
    Jose
  2. Rumen
    Admin
    Rumen avatar
    14361 posts

    Posted 15 Feb 2012 Link to this post

    Hi Jose,

    The content area of RadEditor is an editable iframe which uses the rich text editing engine of the browser under which it operates. The problem is Firefox related and it can be reproduced in an editable iframe as well as in our competitors' DHTML based editors. The issue should be fixed by the browser developers, because there isn't an API or CSS provided by Mozilla which we can use to reposition the table handlders,


    Kind regards,
    Rumen
    the Telerik team
    Sharpen your .NET Ninja skills! Attend Q1 webinar week and get a chance to win a license! Book your seat now >>
Back to Top