Icon Problem

4 posts, 0 answers
  1. Nithya Rani
    Nithya Rani avatar
    47 posts
    Member since:
    Oct 2012

    Posted 21 Feb 2012 Link to this post

    Hi

    For the rad window control i have set the Icon. My icon size is 16*16 only. But my icon not displaying properly in the IE7,IE8 and Google Chrome.

    Please find the attachments.
    Icon Should look like the below image image.
                   original.jpg
    But in IE7 and IE8 and Chrome looks like below image.
             1. ie icon.jpg (IE 7 and IE8)
             2. chrome.jpg(Google Chrome)
  2. Marin Bratanov
    Admin
    Marin Bratanov avatar
    4567 posts

    Posted 22 Feb 2012 Link to this post

    Hello Nithya,

    I have just answered your other thread on the matter and for convenience I am pasting my reply here as well. In the future please post only one thread per issue and if possible in the relevant product forum, as this will ultimately give you a faster and more accurate response.


    This is some really peculiar behavior, what we do is simply set the provided file as the image, we do not modify it in any way. I cropped the image to 16x16px and tested it in all major browsers and things seem to be working fine with me. You can find my test page attached as well as screenshots from the different browsers. Can you confirm you are using the latest version of the controls? Is there any custom CSS on the page and if so - what happens if you remove it? Is it possible that the file you are using is somehow corrupt - please try creating it anew and see what happens. What happens if you set this image as a background image to a simple table cell outside of the RadWindow?

    Regards,
    Marin
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  3. Nithya Rani
    Nithya Rani avatar
    47 posts
    Member since:
    Oct 2012

    Posted 27 Feb 2012 Link to this post

    Hi Marin,

    Till i was facing the same problem. In your case you are using the IE9 and changing the Browser Mode. In this case this will work if you install the IE7 or IE8 and if you check it wont work. See the attachment for chrome. My original image was 16x16 but if i see the details of the image in chrome it showing 32x32.

    Thanks,
    Nithya
  4. Marin Bratanov
    Admin
    Marin Bratanov avatar
    4567 posts

    Posted 29 Feb 2012 Link to this post

    Hello Nithya,

    I tested again and things are working fine with me - you can find attached screenshots, the icon I am using and my test pages. Since Chrome returns wrong dimensions with you it makes me think that the issue is either with your file, or with the server. Please request the image standalone and see what dimensions are returned. My best advise is still to recreate the image, perhaps in png format to make sure things are ok. Since in your case browsers treat the image as 32x32 pixels this is actually the expected display. Once you fix this things should be working properly with the RadWindow as well, since it ultimately relies on the browser to render this image.


    Regards,
    Marin
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
Back to Top