This is a migrated thread and some comments may be shown as answers.

Enter key does not post back

2 Answers 81 Views
ToolBar
This is a migrated thread and some comments may be shown as answers.
ethan
Top achievements
Rank 1
ethan asked on 07 Jan 2009, 08:47 PM
Hello,
I have a RadToolBar with some buttons inside, very similar to this example:
http://demos.telerik.com/aspnet-ajax/Toolbar/Examples/ServerSide/ServerEvents/DefaultCS.aspx

When I click on the button with the mouse it posts back to the server. When I tab to the button and click <Enter> on the keyboard, it does not post back to the server. I recently upgraded to Q3 SP1, previously I was using Q2 and pressing <Enter> on the keyboard worked.

Note that the same situation is true on the above included demo page. Is there a work-around for this issue, or a fix in the upcoming pipeline?

Thanks!



2 Answers, 1 is accepted

Sort by
0
Yana
Telerik team
answered on 08 Jan 2009, 12:03 PM
Hello Ethan,

You are right about this issue, we'll try our best to fix it as soon as possible, you'll be informed once we're ready.

Kind regards,
Yana
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
Yana
Telerik team
answered on 27 Jan 2009, 04:02 PM
Hi there,

I am so sorry for the delayed reply. The issue is already fixed, you can download our next internal build  from your client.net account once it's uploaded and give it a try.

All the best,
Yana
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Tags
ToolBar
Asked by
ethan
Top achievements
Rank 1
Answers by
Yana
Telerik team
Share this question
or