Empty hanging tooltip in scheduler demo

4 posts, 0 answers
  1. Jie
    Jie avatar
    3 posts
    Member since:
    Jun 2008

    Posted 17 Jun 2008 Link to this post

    Hi,
    Recently I've been playing around with the RadScheduler demo using RadTooltip on the online demo site, and I've noticed that when there are a cluster of events on a calendar, occasionally (with some random clicking around), a empty tooltip will appear which will hang on the page. It will not disappear when you mouse out, nor when a new tooltip appears after hovering over a different event.
    I've recreated this problem in my own Radscheduler application, and it only seems to happen only when the sticky property is set to true. I've also captured a screenshot of the hanging tooltip, since the effect is kind of difficult to reproduce.
    I've temporarily set the sticky property to false, but since my application really needs the sticky functionality I was wondering if there's a work-around for this problem? Thanks.
  2. Svetlina Anati
    Admin
    Svetlina Anati avatar
    2795 posts

    Posted 20 Jun 2008 Link to this post

    Hi Jie,

    In our online demo which shows the integration of RadScheduler and RadToolTip and can be found here, the RadToolTip has its Sticky property set to true.

    Would you please try to reproduce the described problem on it? In case you succeed, please send me a detailed explanation of the reproduction steps and the observed behavior.

    In case you are not able to reproduce the problem on the online example, please open a new support ticket and send me a sample, fully runnable reproduction project, explanation of the reproduction steps and some screenshots. Once I am able to examine the problem locally, I will do my best to help.



    Regards,
    Svetlina
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. Jie
    Jie avatar
    3 posts
    Member since:
    Jun 2008

    Posted 24 Jun 2008 Link to this post

    Hi Svetlina,
    I've reproduced the behavior on the online demo and I've taken a screenshot of the hanging tooltip. Let me know if I should send it to you.
    There isn't a set of steps to take to reproduce the behavior, but it will always happen after a minute or so of random clicking in and around the hovering tooltips. (I've found that it's easiest to reproduce in the Month view, since the tooltips appear so closely together).
    The hanging tooltip is completely blank, and will not disappear with the appearance of a new tooltip (or any amount of clicking, time elapsed, etc). However, it will disappear if an edit or insert is initiated.

    Please let me know if there's any other information you need. Thanks!
  4. Svetlina Anati
    Admin
    Svetlina Anati avatar
    2795 posts

    Posted 27 Jun 2008 Link to this post

    Hello Jie,

    I tested the demo but I was not able to reproduce the reported problem.

    Would you please open a new support ticket and send me the screenshot along with a video capture of the reproduction steps? Once I have a better understanding on the problem, I will do my best to help.

    Sincerely yours,
    Svetlina
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
Back to Top