Embedded video issue

2 posts, 0 answers
  1. new
    new avatar
    1 posts
    Member since:
    Jul 2011

    Posted 14 Jul 2011 Link to this post

    Hi,
         I am using SPRadEditor. When I open Image Manager/Media Manager the embedded video(in design mode) is visible on top of the Media Manager even thought the page behind the media manger lost focus. Anyone faced this issue?
  2. Rumen
    Admin
    Rumen avatar
    14031 posts

    Posted 19 Jul 2011 Link to this post

    Hello New,

    This is a DirectX and IE problem which is not related to RadEditor. The Media Player is a windowed object which is always displayed over the HTML elements and the windowed object cannot be controlled with css, javascript or HTML. The RadWindow based editor dialogs are HTML based and for that reason this issue could not be prevented.

    What you try is to configure RadEditor dialogs to use the browsers dialogs as it is shown in this KB article: Using browser modal dialog instead of RadWindow. You can see how to attach to the events of RadEditor for MOSS in this KB article: http://www.telerik.com/support/kb/aspnet-ajax/sharepoint/how-to-execute-custom-code-called-on-radeditor-s-events.aspx You should edit the following file when working with RadEditor for SharePoint 2010 C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\wpresources\RadEditorSharePoint\6.1.6.0__1f131a624888eeed\Resources\SPEditorTools.js

    All the best,
    Rumen
    the Telerik team

    Register for the Q2 2011 What's New Webinar Week. Mark your calendar for the week starting July 18th and book your seat for a walk through of all the exciting stuff we will ship with the new release!

Back to Top