This is a migrated thread and some comments may be shown as answers.
Css Issue with RadDatePicker
2 Answers 66 Views
This is a migrated thread and some comments may be shown as answers.
Phil
Top achievements
Rank 2
Phil asked on 03 Feb 2011, 08:18 PM
Hi:
I am using liquid css with my RadDatePicker, and it works fine in Casini (VS Dev), but not in IIS7.  The Css is as follows:
.field
{
    float: left;
    padding: 5px 30px 5px 0px;
    height: 35px;
}
.field h5
{
    font-size: .9em;
    font-weight: bold;
    padding: 0;
    margin: 0;
}
And the following code demonstrates the issue:
<%@ Page Language="VB" %>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<%@ Register Assembly="Telerik.Web.UI" Namespace="Telerik.Web.UI" TagPrefix="telerik" %>
<script runat="server">
</script>
<head runat="server">
    <title></title>
</head>
<body>
    <form id="form1" runat="server">
        <telerik:RadScriptManager ID="RadScriptManager1" Runat="server">
            <Scripts>
                <asp:ScriptReference Path="Scripts/jquery-1.4.1.js" />
            </Scripts>
        </telerik:RadScriptManager>
        <telerik:RadAjaxPanel ID="orderSelectionRadAjaxPanel" runat="server" CssClass="ScreenWidth">
        <div style="width: 100%; margin: 0px; padding-top: 20px;">
            <div class="field">
                <h5>Top 200 Orders:</h5>
                RadComboBox
            </div>
            <div class="field">
                <h5>Start Date:</h5>
                <telerik:RadDatePicker ID="startRadDatePicker" runat="server"
                    AutoPostBack="True" >
                    <Calendar ID="Calendar1" runat="server" UseRowHeadersAsSelectors="False" UseColumnHeadersAsSelectors="False" ViewSelectorText="x"></Calendar>
                    <DateInput ID="DateInput1" runat="server" DisplayDateFormat="M/d/yyyy" DateFormat="M/d/yyyy" AutoPostBack="True"></DateInput>
                    <DatePopupButton ImageUrl="" HoverImageUrl=""></DatePopupButton>
                </telerik:RadDatePicker>
                <asp:RequiredFieldValidator ID="startValidator1" runat="server"
                    ControlToValidate="startRadDatePicker" ValidationGroup="selectionValidationGroup"
                    ErrorMessage="'Start Date' is required" Text="*"
                    />
            </div>
            <div class="field">
                <h5>End Date:</h5>
                <telerik:RadDatePicker ID="endRadDatePicker" runat="server"
                    AutoPostBack="True" >
                    <Calendar ID="Calendar2" runat="server" UseRowHeadersAsSelectors="False" UseColumnHeadersAsSelectors="False" ViewSelectorText="x"></Calendar>
                    <DateInput ID="DateInput2" runat="server" DisplayDateFormat="M/d/yyyy" DateFormat="M/d/yyyy" AutoPostBack="True"></DateInput>
                    <DatePopupButton ImageUrl="" HoverImageUrl=""></DatePopupButton>
                </telerik:RadDatePicker>
                <asp:RequiredFieldValidator ID="endValidator1" runat="server"
                    ControlToValidate="endRadDatePicker" ValidationGroup="selectionValidationGroup"
                    ErrorMessage="'End Date' is required" Text="*"
                    />
            </div>
            <div class="field">
                <h5>Customers:</h5>
                RadComboBox
            </div>
        </div>
       </telerik:RadAjaxPanel>
    </form>
</body>
</html>

Thanks for you help.
Phil

2 Answers, 1 is accepted

Sort by
0
Phil
Top achievements
Rank 2
answered on 03 Feb 2011, 09:09 PM
See below.
0
Accepted
Phil H.
Top achievements
Rank 2
answered on 04 Mar 2011, 03:16 PM
Hi:
The problem was the validator!
Phil
Tags
Input
Asked by
Phil
Top achievements
Rank 2
Answers by
Phil
Top achievements
Rank 2
Phil H.
Top achievements
Rank 2
Share this question
or