This is a migrated thread and some comments may be shown as answers.

[Solved] Can't run demos - missing file in ~/App_Data?

2 Answers 150 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Bill
Top achievements
Rank 1
Bill asked on 14 Feb 2008, 02:37 AM
I just downloaded the Q3 2007 release of Prometheus.  I'm running VS Express 2008 on WinXP SP2.

When I opened the "Live Demos" in VS, it asked me if I wanted to convert to .NET 3.5, so I said yes, not sure if that was unwise or not, but it didn't appear to give me any choice.  I created a backup though.

Anyway when I attempt to run any of the demos, I get a fatal error in web.config:

"It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.  This error can be caused by a virtual directory not being configured as an application in IIS."

Am I doing anything wrong?  I did note that this line in web.config may have a problem in that there does not appear to be a "TechEd.xml" file in the ~/App_Data directory:

<add name="TechEd" type="Telerik.Web.UI.XmlSchedulerProvider" fileName="~/App_Data/TechEd.xml" persistChanges="true" />

but perhaps that's a red herring.  I can obviously create a dummy teched.xml file but that may be pointless if it's something else...

Thanks in advance,

  -- bill


2 Answers, 1 is accepted

Sort by
0
Bill
Top achievements
Rank 1
answered on 14 Feb 2008, 11:07 PM
Found the problem...

I didn't notice this at first, but not only does VS 2008 convert the Live Demos project and create a backup, it includes the backup files in the converted project.

VS doesn't like having more than one web.config file (well, not strictly true, but certainly it doesn't do well with another completely redundant one).

Perhaps I'm losing it, but I couldn't find the "remove" command to remove it from Solution Explorer, so I created a .zip file of the "backup" subdirectory and deleted it entirely.

Voila, success.
0
Lini
Telerik team
answered on 26 Feb 2008, 08:52 AM
Hello Bill,

Thank you for the information about VS 2008 Express. I am sure that it will be valuable in the future.

The line, referring to ~/App_Data/TechEd.xml in the Web.config is from the RadScheduler configuration. It will not cause any problems with the demos even though this file is no longer in the App_Data folder. The line will be removed in the next release so to prevent confusion.

Regards,
Lini
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
Tags
General Discussions
Asked by
Bill
Top achievements
Rank 1
Answers by
Bill
Top achievements
Rank 1
Lini
Telerik team
Share this question
or