This is a migrated thread and some comments may be shown as answers.

Align agregatte with its column

6 Answers 47 Views
Grid
This is a migrated thread and some comments may be shown as answers.
fer
Top achievements
Rank 1
fer asked on 17 Mar 2009, 01:52 PM
Hi , I'm trying to add some sum agregatte to my grid, and the problem is that when I do that, the are not aligned with their columns.

any ideas?

thanks

6 Answers, 1 is accepted

Sort by
0
Shinu
Top achievements
Rank 1
answered on 18 Mar 2009, 11:48 AM
Hi,

I guess you  are setting the Aggregate property for the Grid Column. If so you can align the aggregate appearing in the Grid footer along with contents of the Grid column by setting its Horizontal-Align property as shown below.

ASPX:

<
telerik:GridBoundColumn UniqueName="ProductName" Aggregate="Count"  HeaderText="ProductName" DataField="ProductName" > 
            <HeaderStyle  HorizontalAlign="Center" /> 
            <ItemStyle  HorizontalAlign="Center" /> 
            <FooterStyle  HorizontalAlign="Center"/> 
          </telerik:GridBoundColumn> 


Thanks
Shinu
0
fer
Top achievements
Rank 1
answered on 18 Mar 2009, 01:31 PM
thanks!
The problem is that whereas the grid is horizontally "scrollable" , the footer with the "sum" fields no, so If I scroll horizontally the grid, the footer field does not match with their columns...The footer is static and it does not move.
any ideas?
thanks!


0
fer
Top achievements
Rank 1
answered on 18 Mar 2009, 06:51 PM
Hi, Now I realized that the problem is only at Firefox. In IE 7 it is working fine.
any ideas?
0
Shinu
Top achievements
Rank 1
answered on 19 Mar 2009, 04:06 AM
Hi Fer,

I was also able to replicate this issue in FireFox when I set the UseStaticHeader property to true. If you have set that to true. Try setting it to false and see if it helps.

ASPX:
  
 <Scrolling AllowScroll="true"  UseStaticHeaders="false" /> 

Regards
Shinu.



0
Tom
Top achievements
Rank 1
answered on 23 Mar 2009, 02:15 PM
I am having the same issue... scrolling looks great in IE but the footer in FireFox is all Garbled.

<Scrolling AllowScroll="True" UseStaticHeaders="true" SaveScrollPosition="false" FrozenColumnsCount="0"></Scrolling>

 

0
Iana Tsolova
Telerik team
answered on 23 Mar 2009, 02:38 PM
Hi Tom,

Try setting the TableLayout property of the MasterTableVIew to Fixed and see if it makes any difference.
<telerik:RadGrid ID="RadGrid1" runat="server">  
    <MasterTableView TableLayout="Fixed" />   
</telerik:RadGrid> 

Check this demo for more information about grid footer aggregates.

I hope this helps.

Kind regards,
Iana
the Telerik team

Check out Telerik Trainer , the state of the art learning tool for Telerik products.
Tags
Grid
Asked by
fer
Top achievements
Rank 1
Answers by
Shinu
Top achievements
Rank 1
fer
Top achievements
Rank 1
Tom
Top achievements
Rank 1
Iana Tsolova
Telerik team
Share this question
or