This is a migrated thread and some comments may be shown as answers.

Ajax issue for SharePoint

2 Answers 90 Views
Sharepoint Integration
This is a migrated thread and some comments may be shown as answers.
salman
Top achievements
Rank 1
salman asked on 09 Jul 2008, 06:36 PM
Hi,

I have hosted a RadSchduler as a composite control in the SharePoint 2007.  It works fine without Ajax.  However, when I integrated with RadAjaxPanel, it will do something at first time and then it's kind of hung.  Each time I manually referesh the page, it will work only once than it won't do anything.   Do you know what could be the issue here?

I have hosted RadScripManager at the masterpage and RadAjaxPanel and RadAjaxLoadingPanel at the page where RadSchdular is hosted.

I've also register the Telerik.Web.UI.WebResource.axd in the web.config.

Any suggestions would be appereciated.

Thank you,
-Salman

2 Answers, 1 is accepted

Sort by
0
Accepted
Rosen
Telerik team
answered on 14 Jul 2008, 02:15 PM
Hello,

Unfortunately I was unable to recreate this behavior. Therefore it will be highly appreciated if you can send us(attached to a formal ticket) a small working project in which this behavior can be reproduced.

Meanwhile I have attached a simple webpart with which I have tested. Please give it a spin and let us know if it helps or if I'm missing something obvious.

Greetings,
Rosen
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
0
salman
Top achievements
Rank 1
answered on 15 Jul 2008, 03:18 PM
Hi Rosen,

It's working as expected now.  The only difference I would say is that I'm using your EnsureUpdatePanelFixups method and the RadScriptManager is hosted on the same page instead of hosting on the MasterPage as I had it before. 


Thank you for your help!
Salman
Tags
Sharepoint Integration
Asked by
salman
Top achievements
Rank 1
Answers by
Rosen
Telerik team
salman
Top achievements
Rank 1
Share this question
or