Click not opening panel in .net Framework 4 when the web page is not specified in the browser address line

1 posts, 0 answers
  1. Jay
    Jay avatar
    1 posts
    Member since:
    Feb 2012

    Posted 18 Feb 2012 Link to this post

    I am having an interesting problem when I upgraded the .NET Framework from 2.0 to 4.0.  The problem exists in all browsers that I have tried so I don't think it is browser related.

    The problem is as follows:

    If I enter just the domain name it brings up the default page served up by the web server.   If I click on the panel bar it will not expand.  I've even tried opening the page with one panel expanded to see if I can click on another one to close that one and have the clicked one open.  In that case, although the one I set to open is open when the page opens, I cannot get the other panel to open when I click on it.

    The panels worked fine using .NET Framework 2.0 though.  But the most interesting thing is that if I specify the default page in the browser (e.g., instead of just the domain name ( then it all works like it should (i.e., when I click on a panel it opens up fine).  Thus the problem occurs on pages that I don't specify explicitly but that the server uses by default.  My web server is IIS 6.0.

    Is this a bug in the PanelBar control?

Back to Top