This is a migrated thread and some comments may be shown as answers.

 Special Character

1 Answer 36 Views
Editor
This is a migrated thread and some comments may be shown as answers.
Susan
Top achievements
Rank 1
Susan asked on 15 Oct 2008, 04:20 AM
I typed text for an email into the editor. I did not copy from word. the text looks fine, the html looks fine, but when the email is sent, a special character is inserted in different places. below is a partial copy of the email:

 
The 2008 Winter Basketball Season registration is now open! Go to the PYSA

How do I remove this?

Thanks,
Susan

1 Answer, 1 is accepted

Sort by
0
Rumen
Telerik team
answered on 15 Oct 2008, 07:32 AM
Hi Susan,

Having Â's around means that you probably do not save the file with the correct encoding - or, alternatively, you save it in one encoding, but display on a page with a different encoding. Our suggestion is to check and make sure all is saved with the same encoding.

Please, try the suggestions provided in the following help article:
Appearance of odd characters after saving RadEditor's content in Database.

You can save the ascx file with Unicode encoding using Visual Studio -> File -> Save <PageName> As -> Click on the bottom arrow dropdown button next to the Save button -> choose Save with Encoding -> choose Unicode (UTF-8 with signature).

You have to also set <globalization fileEncoding="UTF-8"/> in your web.config file.

Here are some links that discuss [file] encoding.

http://support.microsoft.com/kb/893663
http://msdn.microsoft.com/en-us/library/39d1w2xf.aspx
http://weblogs.asp.net/ssadasivuni/archive/2005/01/19/355935.aspx

Best regards,
Rumen
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Tags
Editor
Asked by
Susan
Top achievements
Rank 1
Answers by
Rumen
Telerik team
Share this question
or