This is a migrated thread and some comments may be shown as answers.

WSS3, styles not displayed in the editor

1 Answer 14 Views
WebParts for SharePoint
This is a migrated thread and some comments may be shown as answers.
Thomas
Top achievements
Rank 1
Thomas asked on 22 Oct 2008, 12:28 PM
Hi

I have just (successfully) installed the LITE version of the RAD Editor and it even displays my custom CSS styles (I defined them in CssEditor.css). So basically everything is fine - well, nearly.

When I open the editor, no CSS overlay is used. By that, I mean that the styles are not displayed as they are displayed later on (which is ok). Is this the default behaviour or should the Editor show the final style directly?

I am using Sharepoint Services (no the Sharepoint Server) and I cannot find the files you mentioned (HtmlEditorCustomStyles.css, HtmlEditorTableFormats.css). In the given directory I can only find the files: calendar.css, core.css, datepicker.css, help.css, menu.css, owsnocr.css.

Thank you for your response

1 Answer, 1 is accepted

Sort by
0
Lini
Telerik team
answered on 24 Oct 2008, 08:51 AM
Hello Thomas,

The editor content area is a separate document so its styles are also separate from the rest of the page. This means that only the styles in CssEditor.css will be applied in the editor content area. The rest of the styles defined on the page will be ignored. You will need to copy all styles you want to see in the editor to the CssEditor.css file.

Best wishes,
Lini
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Tags
WebParts for SharePoint
Asked by
Thomas
Top achievements
Rank 1
Answers by
Lini
Telerik team
Share this question
or