This is a migrated thread and some comments may be shown as answers.

when i run then occure this error

3 Answers 58 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Bhavesh
Top achievements
Rank 1
Bhavesh asked on 03 Jul 2009, 12:56 PM
Hello All,
         Could not load file or assembly 'Telerik.Web.UI, Version=2008.2.826.35, Culture=neutral, PublicKeyToken=121fae78165ba3d4' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)


give me solution and how to solve it and how change my web.config file in that version.

it's urgent

3 Answers, 1 is accepted

Sort by
0
Daniel
Top achievements
Rank 1
answered on 03 Jul 2009, 02:49 PM
Hi Bhavesh,

Have you replaced your Telerik.web.UI dll in the bin folder. This tends to happen when you have updated your telerik controls.
0
Bhavesh
Top achievements
Rank 1
answered on 04 Jul 2009, 05:29 AM
Hello,
        i have installed newer version of telerik control and in my project used old version of telerik control dll file. when i used newer version dll file in my project then that error fired.
        So, how to overcome this error. give me solution whether what changes in web.config file or old version telerik contol.

    Regards
   Bhavesh Rana
0
Svetlina Anati
Telerik team
answered on 06 Jul 2009, 11:59 AM
Hi Bhavesh,

I am not completely sure what is the exact reason for the problem but in case you have completely uninstalled and than installed the RadControls as recommended I assume that you might have fully qualified names of the previous version in your project. This being said, please find all the occurrences of the following string:

 'Telerik.Web.UI, Version=2008.2.826.35, Culture=neutral, PublicKeyToken=121fae78165ba3d4'


with simply


'Telerik.Web.UI"


and test again whether this fixes the issue. Note, that most of the occurrences of this fully qualified name should be in the Web.config but also make sure that you have not registered it also on certain page where you register the assembly.

Let me know if this fixes the issue on your side and in case it does not, provide more details about the exact manner you upgrade your controls.


Best wishes,
Svetlina
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Check out the tips for optimizing your support resource searches.
Tags
General Discussions
Asked by
Bhavesh
Top achievements
Rank 1
Answers by
Daniel
Top achievements
Rank 1
Bhavesh
Top achievements
Rank 1
Svetlina Anati
Telerik team
Share this question
or