Upgrade from Version 2011.2.915.40 to 2012.3.1308.40

8 posts, 0 answers
  1. Bilal
    Bilal avatar
    2 posts
    Member since:
    Jan 2013

    Posted 29 Jan 2013 Link to this post

    I'm getting this run time error:

    Could not load file or assembly 'Telerik.Web.UI, Version=2011.2.915.40, Culture=neutral, PublicKeyToken=121fae78165ba3d4' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

    Can you give an update tutorial and help me solve the above problem. I can't find references to the old assembly in my project or in the GAC.

    Thanks in advance.
  2. Kate
    Admin
    Kate avatar
    1898 posts

    Posted 29 Jan 2013 Link to this post

    Hello Bilal,

    Please take a look at the following forum post where you can find more information related to the issue that you get - Finding assembly.

    All the best,
    Kate
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  3. Bilal
    Bilal avatar
    2 posts
    Member since:
    Jan 2013

    Posted 30 Jan 2013 Link to this post

    I have updated the references but I'm still getting the same error :-( do you have more suggestions?

    Update:
    I found out that I reference third party assembly that has a dependency on Version 2011.2.915.40.

    Thanks for the help.
  4. Kate
    Admin
    Kate avatar
    1898 posts

    Posted 30 Jan 2013 Link to this post

    Hi Bilal,

    Another suggestion that you can try out is to use a web.config file where the version of the Telerik controls is not explicitly specified. Attached to this post you can find such example.

    Regards,
    Kate
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  5. Melinda
    Melinda avatar
    1 posts
    Member since:
    Feb 2013

    Posted 18 Jul 2013 Link to this post

    I had the same error when upgrading to 6.1 version. I'm very worried about the resolution to the problems being update the webconfig to point to a different version. It seems like that will just end up causing more frustration in the long run with future upgrades. Has anyone found another solution to this issue?

    Thanks.
  6. Kate
    Admin
    Kate avatar
    1898 posts

    Posted 19 Jul 2013 Link to this post

    Hi Melinda,

    Can you please clarify the two versions of the RadControls that you are using since we do not have a 6.1 version of the RadControls? Meanwhile I can suggest that you refer to the following forum post where you can find more information on upgrading to a different version of the RadControls - Upgrade the Version of Your Telerik ASP.NET Controls in 6 Easy Steps

    Regards,
    Kate
    Telerik
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
  7. Jamil
    Jamil  avatar
    1 posts
    Member since:
    Mar 2014

    Posted 27 Mar 2014 Link to this post

     I'm getting this run time error:



    Could not load file or assembly 'Telerik.Web.UI, Version=2014.1.225.35,
    Culture=neutral, PublicKeyToken=121fae78165ba3d4' or one of its
    dependencies. The located assembly's manifest definition does not match
    the assembly reference. (Exception from HRESULT: 0x80131040)



    Can you give an update tutorial and help me solve the above problem. I
    can't find references to the old assembly in my project or in the GAC.



    Thanks in advance.
  8. Kate
    Admin
    Kate avatar
    1898 posts

    Posted 01 Apr 2014 Link to this post

    Hello Jamil,

    The exception that you are getting indicates that somewhere in your project you are referencing an old version of the Telerik control as well. Did you try out the suggestions in the previous posts? If you have and you still experience the issue I would suggest that you open a support ticket where you can attach your sample project so we can inspect it thoroughly from our side and assist you in the most efficient way in resolving the issue  that you are currently getting.

    Regards,
    Kate
    Telerik
     

    Build cross-platform mobile apps using Visual Studio and .NET. Register for the online webinar on 03/27/2014, 11:00AM US ET.. Seats are limited.

     
Back to Top