This is a migrated thread and some comments may be shown as answers.

Toolbar layout broken

3 Answers 63 Views
Editor
This is a migrated thread and some comments may be shown as answers.
Steve
Top achievements
Rank 2
Steve asked on 01 Apr 2010, 04:37 PM
Hi,

I have a very simple Editor included on my page.  It displays correctly for most users, but in a few instances the editor renders with toolbar layout broken (see attached image).  This seems to happen only on IE7 (works fine with Firefox) and it's across all different resolutions/screen settings.  Any idea what could be causing this?

Thank you,

Marek

3 Answers, 1 is accepted

Sort by
0
Rumen
Telerik team
answered on 02 Apr 2010, 12:15 PM
Hello Marek,

Such a problem could arise if the DOCTYPE of the page is missing or if it is not XHTML.

You should make sure that you use the latest version 2010.1.309 (Q1 2010) of RadEditor for ASP.NET AJAX and that a XHTML doctype is set as the below one:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

If you unable to solve the problem with the above doctype and latest version, please open a support ticket and send a sample working project that demonstrates the appearance issue. I will examine it and provide a solution.

Kind regards,
Rumen
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
Steve
Top achievements
Rank 2
answered on 02 Apr 2010, 03:08 PM
Rumen,

I'm already using the latest version and have a valid doctype.  As for sending a support ticket - really no point because chances are that it simply won't show up incorrectly on your end (there are only so many computers around here that I can reproduce the issue on).

Thanks for the help.
0
Rumen
Telerik team
answered on 05 Apr 2010, 12:15 PM
Hello Marek,

Can you please reset  Internet Explorer Settings as it is explained in this blog post: http://blogs.msdn.com/ie/archive/2006/06/12/628499.aspx?

Another suggestion is to set the Zoom level to its default value of 100% (if it is changed).

Finally, disable the page stylesheet and test again.

Best regards,
Rumen
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Tags
Editor
Asked by
Steve
Top achievements
Rank 2
Answers by
Rumen
Telerik team
Steve
Top achievements
Rank 2
Share this question
or