Solution: Rotator stops rotating if ScrollDuration = 0

2 posts, 0 answers
  1. Michael
    Michael avatar
    1 posts
    Member since:
    Apr 2009

    Posted 28 Nov 2012 Link to this post

    I created an "article rotator" for a magazine using the RadRotator back in Spring 2011.  All worked well until I updated the Telerik assemblies from version 2010.2 to 2012.2SP1.  Soon after, I noticed that my rotators would do one transition, then stop.  There were no javascript errors or anything other problems I could detect.  I eventually discovered the problem.  I want immediate transitions (no "swipe" appearance during scrolls).  The older versions used to allow ScrollDuration = 0 for the effect.  However, for some reason, this is no longer the case.  If I simply change ScrollDuration = 1, then all works well again (and 1 millisecond is not noticeable).  

    I was unable to find anybody else discussing this specific problem, so I figured I'd post just in case there are some other late adopters to the 2012 assemblies who may encounter this problem.  I'm not sure when things changed, but it was somewhere between early 2011 and mid 2012.  Hope this helps somebody.
  2. Slav
    Slav avatar
    1359 posts

    Posted 03 Dec 2012 Link to this post

    Hello Michael,

    Indeed, the problem you described is a bug in the RadRotator. I have brought this to the attention of our developers, nevertheless I cannot provide a firm estimate when a solution will be available. You can follow the status of the issue, vote for it and comment it via the PITS Item that I logged.

    For the time being you can workaround this problem by setting ScrollDuration to 1, as you suggested in your post.

    I have updated your Telerik points as a token of gratitude for reporting the bug.

    All the best,
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
Back to Top