This is a migrated thread and some comments may be shown as answers.

Several problems with RadControls Skins

4 Answers 52 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Michelle
Top achievements
Rank 1
Michelle asked on 23 Jul 2010, 06:11 PM
Hi to all!
Some days ago I've downloaded Q2 2010 ASP.NET AJAX Trial and now I'm trying to do an example web app.
I've done all correctly and It function very good but now I have a problem. I use about 3/4 different Skins for page (Sitefinity for RadPanelBar, Windows7 for RadWindow, and my self created skins with stylebuilder). It's possible to do this? 
Because when I add RadWindow or RadEditor happens the... I can't describe the problem, I show you it on images.
        1) Telerik RadControls before (PanelBar, ToolTip)
         
        2) Controls after adding RadWindow or RadEditor
         

Thanks for your help and sorry for my english!
Michelle

4 Answers, 1 is accepted

Sort by
0
Michelle
Top achievements
Rank 1
answered on 29 Jul 2010, 08:09 AM

Nobody has a solution?
Plaese help me, I must show a preview of the project to my boss tommorow!

Thanks in advance,
Michelle

0
Rumen
Telerik team
answered on 30 Jul 2010, 02:59 PM
Hi Michelle,

I suppose that you are using some global CSS styles for TABLE. TR, TD, UL, LI, that sets tot he RadWidnow and RadEditor elements some additional styles and this breaks the layout.

When you are using third party controls such as Telerik`s it is not recommended to use Global CSS styles, as they easily could apply additional styles to the control`s HTML elements. Try to disable your additional CSS and check if the problem still exists.

Another option is to send us a live url, where the project exists, and we will be able to investigate it further.


Best regards,
Rumen
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
0
Michelle
Top achievements
Rank 1
answered on 30 Jul 2010, 09:34 PM
Hi Rumen,

Thank you so much for your answer! You was very helpfull for me!
I'm so happy to say you that I probably found the source of the problem.
I'm using a lot of CSS style sheets, some for page layout (and there can't be problems).
I've created some custom skins with stylebuilder.telerik.com. When I using my customs css styles that I use for RadControls the problems persist (I've created them with stylebuilder.telerik.com), after I deleted them it works perfectly (of course RadControls that are using custom skin don't work perfectly).
So I think the default Skins (Sitefinity, Windows7, Simple) mix their CSS styles with my owned created skins.
What I have to do? Have I done wrong anything?

Thanks in advance,
Michelle

0
Rumen
Telerik team
answered on 03 Aug 2010, 12:09 PM
Hi Michelle,

It seems that your custom skins mix the base stylesheet of built-in skins of RadControls controls.

Could you please open a support ticket and send a sample working project that demonstrates the problem? Please include all project files and folders including your custom CSS files.

We will examine them, reproduce the problem and do our best to provide a solution.

Best regards,
Rumen
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Tags
General Discussions
Asked by
Michelle
Top achievements
Rank 1
Answers by
Michelle
Top achievements
Rank 1
Rumen
Telerik team
Share this question
or