This is a migrated thread and some comments may be shown as answers.

Service Mark Symbol

1 Answer 24 Views
Editor
This is a migrated thread and some comments may be shown as answers.
Terri
Top achievements
Rank 1
Terri asked on 15 Jun 2010, 04:46 PM
Please forgive me this has already been answered but I'm working on a project where I need to add the service mark symbol as an option in the RadEditor's Symbol dropdown. I've added the unicode for the symbol to ToolsFile.xml (<symbol value="\u2120" />). And while it displays ok in FF 3.6 and somewhat in IE7, it displays as an unidentified symbol in IE6. Is the service mark symbol supported in the editor like the other predefined symbols or would I need to do some sort of conversion?

Thanks! 

1 Answer, 1 is accepted

Sort by
0
Rumen
Telerik team
answered on 16 Jun 2010, 06:52 AM
Hello Terri,

This is a browser IE6 bug, which can be reproduced in an editable IFRAME element as well as in our competitors' editors under IE6. You can confirm this by testing the attached HTML file having an editable IFRAME element in it.

If you change the font to Verdana, Tahoma, Georgia, Courier New the special symbol will be rendered fine. I was able to reproduce that the browser bug occurs when the font is set to Arial or Times New Roman.

I found that this browser bug is also discussed in these web pages:

http://getsatisfaction.com/typekit/topics/problems_with_unicode_html_entities_rendering_in_ie6

http://www.imarc.net/communique/82-the_servicemark_sm_and_the_web

Best regards,
Rumen
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Tags
Editor
Asked by
Terri
Top achievements
Rank 1
Answers by
Rumen
Telerik team
Share this question
or