This is a migrated thread and some comments may be shown as answers.

Scheduler Web Part w/Exchange - time zone wrong

3 Answers 20 Views
WebParts for SharePoint
This is a migrated thread and some comments may be shown as answers.
Robert Manjoney
Top achievements
Rank 1
Robert Manjoney asked on 09 Sep 2013, 02:45 PM
I'm using a Scheduler Web Part against Exchange server as it's data source. All calendar events in the web part seem to be presenting in UTC 0 time zone, rather than the local time zone, and I cannot find a way to change this setting.

I did read some API documentation that states in the absence of explicitly setting a time zone for the control, it will default to UTC 0 which is exactly what appears to be happening, however, there is not a settable web part property in the GUI in SharePoint for changing the Time Zone, nor can I figure out how to code it manually.

I've verified the regional settings on my SharePoint server are all correct for our local time.

Any help appreciated!
Bob

3 Answers, 1 is accepted

Sort by
0
Boyan Dimitrov
Telerik team
answered on 12 Sep 2013, 02:23 PM
Hello Bob,

I am afraid that the in case of populating RadScheduler using the Exchange provider time zones are not supported. In this case time zones could not be changed.

Please excuse for this limitation.


Regards,
Boyan Dimitrov
Telerik
If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
0
Robert Manjoney
Top achievements
Rank 1
answered on 22 Sep 2013, 09:25 PM
This seems like a bug - let me explain again - if I create an appointment from within Outlook on my local machine, to my local Exchange Server, and then display that same event from my local SharePoint server in a RadScheduler web part on same local machine, it displays fine - the time on Outlook and the Web Part are the same.

The moment I edit the appointment from SharePoint RadScheduler and save it, it shifts the time seemingly to UTC and displays the event shifted in time both in SharePoint and back on Exchange/Outlook. The appointment is now screwed up.

Bob
0
Boyan Dimitrov
Telerik team
answered on 26 Sep 2013, 07:18 AM
Hello,

Could you please confirm whether you are setting any of the RadScheduler TimeZoneID or TimeZoneOffset properties? Please clarify whether you have same time zone settings on local machine and Exchange/Outlook server?

Regards,
Boyan Dimitrov
Telerik
If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
Tags
WebParts for SharePoint
Asked by
Robert Manjoney
Top achievements
Rank 1
Answers by
Boyan Dimitrov
Telerik team
Robert Manjoney
Top achievements
Rank 1
Share this question
or