This is a migrated thread and some comments may be shown as answers.

Rotator doesn't appear

3 Answers 14 Views
Rotator
This is a migrated thread and some comments may be shown as answers.
Роберт
Top achievements
Rank 1
Роберт asked on 19 Sep 2015, 10:59 AM

Hello Dear Friends,

 I'm sick and tired searching for an error with my rotator.

 Before I put the code in here, I would like if someone could direct me where is the error could be.

I worked ok for years under Win XP IIS 5.
After I transited to Win 7 - it stopped working.
I have 2 rotators.

1) Static. it just rotates pictures to left/right withput interactin.

2) Dynamic. it is filling with Web controls (panels) with questions and answers (questionary pages)

 The 1-st works, 2-nd doesn't...

IIS is set to .NET 4, Telerik.WebControl.UI.dll also 4-th

If I look into page code after the RadControl is dinamically created, then I can see all pages in code. Also, it's important, the RadRotator is also created without error.
But there is no Rotation and it is not visible at all, though, as I said before, the code is generated ok.
I tried IE and Chrome with the same result.

Please, help me where to go... I spent already several days with that transition from XP to W7. I needed to recreate 2 DBs and connect them to old code..
And one of the DBs was Oracle.. I was so much pain for me..

Now I'm just close to the end, and it's Rotator... maybe you already have met that kind of behavior - invisibility?

3 Answers, 1 is accepted

Sort by
0
Роберт
Top achievements
Rank 1
answered on 19 Sep 2015, 11:04 AM

I forgot to mention the very important thing - it works Ok in Debugging mode, but after publishing in its directory - doesn't appear, as I described above.

Thanks for your suggestions.

0
Роберт
Top achievements
Rank 1
answered on 19 Sep 2015, 11:33 AM
After the both pages are generated (under Debug and direct link from http) - they have the same generated code.
I pretty much sure my problem is in AppPool settings in IIS, but what are those settings?
0
Роберт
Top achievements
Rank 1
answered on 19 Sep 2015, 11:55 AM

As  it usually happens, after I formulated the problem carefully, it's easier to find the solution.

Yes, it was IIS settings.

 Goto IIS administration.

Select Applicatios Pool with your name

On right panel you'll General Settings.
Then you will be shown small dialog window

See the image, it's in Russian...

 

Tags
Rotator
Asked by
Роберт
Top achievements
Rank 1
Answers by
Роберт
Top achievements
Rank 1
Share this question
or