Radwindow Issues in Firefox 3.0.5

6 posts, 0 answers
  1. Shailendra
    Shailendra avatar
    22 posts
    Member since:
    Jul 2008

    Posted 12 Jan 2009 Link to this post

    Hello,

    I am using Rad Controls Ver. 2008.01.0415.35. I have noticed few issues when viewing the site in Firefox 3.0.5.

    1. I have a radwindow one page and after closing it and pressing back button that radwindow is displayed instead of the main previous page. On top of that all the behavior icons disappear and there is no way to close the radwindow. Window is frozen and if its a modal window you cannot navigate to any other page. Refresh is the only option. Is there any way to prevent radwindow from opening on back button? I have put the screenshot below.
      http://img212.imageshack.us/img212/5143/radwindowff3hf9.jpg
    2. In IE 7, if i press ESC key it closes the window while in FF it doesnt. Is there any fix for this? I dont want ESC key to close the radwindow.
    3. I have a flash object and RadCalendar on one page. When I click on calendar it displays behind the flash object. Setting Z-Index wont help. While this works fine in IE. Same is the case with modal tooltip and alert.

    Thanks
    ~SP
  2. Fiko
    Admin
    Fiko avatar
    1406 posts

    Posted 14 Jan 2009 Link to this post

    Hi Shailendra,

    Up to your questions :
    1. I prepared a sample demo based on the provided information and tried to reproduce the problem but to no avail. I also do not know your exact configuration so I tested with Modal property set to true and false for the RadWindow but in all the described cases there were no any freezing problems.

      This being said, I need to examine your exact code and for your convenience I attached my test demo to the thread - it is fully working, you should just modify it in order to replicate the issue. Once you succeed, please open a new support ticket and send me the modified demo along with detailed reproduction steps.
    2. You can do this by overriding the close() function of RadWindow. You can examine it in the attached project.
    3. The Overlay property works on IE only and we do not have a solution for Gecko-based browsers at the moment. The problem lies in the fact that Gecko-based browsers treat HTML elements differently and we cannot provide a better way to overlay the RadTooltip, RadCalendar, etc. over flash object.
      A possible workaround is to set the following attribute to the flash object :
      wmode="opaque" or wmode="transparent"
      I show how can this be done in the attached project.

    I hope this helps.

    Sincerely yours,
    Fiko
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  3. Shailendra
    Shailendra avatar
    22 posts
    Member since:
    Jul 2008

    Posted 19 Jan 2009 Link to this post

    Hi Fiko,

    Thanks for your reply. I have been busy with some other work so could not respond before. I have fixed the issue of opening radcalendar above a flash control using 'wmode' property. I haven't yet looked at the ESC key workaround. I will do that in a day or two. And I forgot to mention that freezing behavior of radwindow happens when you resize the window on load and you close it before it loads. I will get back to you again in a couple of days.

    Thanks again,
    ~SP
  4. aaoz gull
    aaoz gull avatar
    2 posts
    Member since:
    Oct 2009

    Posted 22 Oct 2009 Link to this post


          im also facing same problem in radwindow. Sometime, radwindow default control doest appear and it don't render proberly. im attaching the screenshot.

    Thanx
    aaoz
  5. Fiko
    Admin
    Fiko avatar
    1406 posts

    Posted 23 Oct 2009 Link to this post

    Hi Guys,

     #Shailendra : I recommend you add the code bellow just before the closing form tag on the page that contains the RadWindow's declaration (SecondPage.aspx in the previously attached project) :
    <script type="text/javascript">
        Telerik.Web.UI.RadWindowController.hideCurrentWindowIfNonModal = function() { }
    </script>

    #Aaoz: I am not quite sure what type of object hides the RadWindow control. If this is a Flash object, could you please try the suggested solution earlier in this thread? In case this is a Silverlight object, please try setting the Windowless="true" to the Silverlight object. If the case is different than described ones, please, open a new support ticket and send me the project that reproduces the problem. I will check it and do my best to provide a working solution.

    Kind regards,
    Fiko
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  6. aaoz gull
    aaoz gull avatar
    2 posts
    Member since:
    Oct 2009

    Posted 02 Nov 2009 Link to this post

    Hi Shailendra,

                         Thanx ur reply. Im not using flash object. I'm using radWindow & open it when user click on "<a "(anchor) tag. This problem occure in real. Mean this window open properly but sudden that probelm occure that snapshot given in my last post

    as below

     <div id="divFeature" runat="server">
                                    <a href="javascript:void(0)" id="FeatureLink">                                  
                                        <asp:Image ImageUrl="~/Images/features/feature.bmp" ID="imageID" runat="server" />
                                    </a>
                                    <telerik:RadWindow ID="FeatureWindow" OpenerElementID="FeatureLink" Width="425px"
                                        Height="400px" runat="server" ReloadOnShow="true" VisibleStatusbar="false" KeepInScreenBounds="true"
                                        Skin="WebBlue" OnClientClose="FeatureWindow_ClientClose" Behaviors="Close" Modal="True">
                                    </telerik:RadWindow>
                                </div>

    when user click on <a tag id ="FeatureLink"  then  radwindow  ID="FeatureWindow" open a new aspx page inside window.Its NavigationURl set on code behind on page load.

    that page open when radwindow open:

    <%@ Page Language="C#" AutoEventWireup="true" CodeFile="Features.aspx.cs" MasterPageFile="~/Blank.master"
        Inherits="Connect_Publish_Application_Details_Features" %>

    <%@ Register Assembly="Telerik.Web.UI" Namespace="Telerik.Web.UI" TagPrefix="telerik" %>
    <asp:Content ContentPlaceHolderID="head" ID="ContentPlaceHolderID1" runat="server">
    </asp:Content>
    <asp:Content ContentPlaceHolderID="ContentPlaceHolder1" ID="ContentPlaceHolderID2"
        runat="server">

      <telerik:RadAjaxLoadingPanel ID="RadAjaxLoadingPanel1" runat="server" Height="75px"
            Width="75px">
            <img alt="Loading..." src='<%= RadAjaxLoadingPanel.GetWebResourceUrl(Page, "Telerik.Web.UI.Skins.Default.Ajax.loading.gif") %>'
                style="border: 0px;" />
        </telerik:RadAjaxLoadingPanel>
    </asp:Content>

    regards

    aaoz






Back to Top