This is a migrated thread and some comments may be shown as answers.

RadWindow IFRAME CSS styling problem

1 Answer 96 Views
Window
This is a migrated thread and some comments may be shown as answers.
Josh
Top achievements
Rank 1
Josh asked on 09 Apr 2010, 12:08 AM
Dear Support,

I find that the page that I am loading into my RadWindow doesn't apply the styles in the app_themes directory. 
All the css and skin files are not shown in the head tag for the IFRAME page, but rather there are three tags that look like the below tag.

<LINK class=Telerik_stylesheet rel=stylesheet type=text/css href="/MASTRR/WebResource.axd?d=v9c6FiMMBVCv_RS52za5rWMWEoR0I4urecGaHYdAaM66IofJWOuBO54LLe4t682T0&amp;t=633868167800000000">  
 
 

Is there a way to have the page within the IFRAME use the linked CSS that exists in the Parent Page?

Thanks for your anticipated help,
Josh

1 Answer, 1 is accepted

Sort by
0
Georgi Tunev
Telerik team
answered on 14 Apr 2010, 12:00 PM
Hi Josh,

The IFRAME is a container that loads a page that is separate from the parent one. The style that you apply in the main page cannot be inherited on the content page - you need to manually set it there as well.


Greetings,
Georgi Tunev
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Tags
Window
Asked by
Josh
Top achievements
Rank 1
Answers by
Georgi Tunev
Telerik team
Share this question
or