This is a migrated thread and some comments may be shown as answers.

RadSplitter and MOSSRadEditor on the same page causes splitter bug

3 Answers 27 Views
Sharepoint Integration
This is a migrated thread and some comments may be shown as answers.
Loïs
Top achievements
Rank 2
Loïs asked on 22 May 2012, 10:36 AM
Hello,

I have these two controls on the same page, the splitter containing a RadTreeview, a Formview and a gridview (left, right and bottom panes).
When I add a MOSSRadEditor, the vertical splitter shows a horizontal resizing icon, and allows resizing "horizontally" (though the orientation is "Vertical")...

Is there a workaround ?

3 Answers, 1 is accepted

Sort by
0
Rumen
Telerik team
answered on 24 May 2012, 01:01 PM
Hi,

I am not aware of this problem and you are the first to report it. Do you experience the problem with the latest version of RadControls for ASP.NET AJAX Q1 2012 SP1 and RadEditor for MOSS 5.8.15?

If the problem is reproducible with the latest versions, please, isolate it in a webpart which we can test locally and send it via a support ticket.

Regards,
Rumen
the Telerik team
If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
0
Loïs
Top achievements
Rank 2
answered on 24 May 2012, 02:57 PM
Hello Rumen,

I confirm that the controls are in the last version:
- RadControls for ASP.NET AJAX Q1 2012
- RadEditorSharePoint, Version=6.3.0.0 (though it is not the same as the one you wrote about, but I just picked the assembly version)

I downloaded the two products very recently (last month or so), as we just bought the RadControls for ASP.NET.

So what I need to do now is to create a simple page for SharePoint, reproducing the problem,  that you can test, right ?
0
Rumen
Telerik team
answered on 28 May 2012, 08:12 AM
Hello,

Thank you for the provided project in your ticket.

I tested it with and without SPRadEditor and I was unable to reproduce the reported problems as shown in the following video: http://screencast.com/t/0DzfwfUt65. This leads me believe that the problems could be due to some global CSS class(s) in your custom stylesheet that is breaking the appearance and functionality of the controls. Could you please disable the site specific stylesheet and test again the page? You can also inspect the page with IE developer toolbar / Firebug and see which classes are causing the issues.

If you are unable to fix the issues, please, give us more information how to reproduce them with the provided sample project.

Greetings,
Rumen
the Telerik team
If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
Tags
Sharepoint Integration
Asked by
Loïs
Top achievements
Rank 2
Answers by
Rumen
Telerik team
Loïs
Top achievements
Rank 2
Share this question
or