This is a migrated thread and some comments may be shown as answers.

RadGrid Paging

1 Answer 52 Views
Ajax
This is a migrated thread and some comments may be shown as answers.
IT
Top achievements
Rank 1
IT asked on 13 Jul 2017, 09:29 AM

Hi,

 

I am trying to implement paging on a RadGrid in a web forms application.

The problem I am having is that when the user selects a page the correct information displays, but then the text '22057|updatePanel|ctl00_MainContent_ctl00_MainContent_grdResultsPanel|'

erroneously appears above the control after which the paging no longer functions. I have attached part of a screenshot so you can see what I'm talking about.

Why is this happening?

 

 

 

ASPX:

<telerik:RadGrid ID="grdResults" runat="server" Width="100%" Height="430px" PageSize="10"
                   ItemStyle-HorizontalAlign="Left" HeaderStyle-HorizontalAlign="Left"
                   OnItemCommand="grdResults_ItemCommand" OnItemDataBound="grdResults_ItemDataBound"
                   AllowPaging="True"
                   AlternatingItemStyle-HorizontalAlign="Left" ItemStyle-BackColor="#ffffff"
                   AlternatingItemStyle-BackColor="#eeeeee" Visible="true"
                   AutoGenerateColumns="false"
                   OnNeedDataSource="grdResults_NeedDataSource">
                   <MasterTableView TableLayout="Auto">
                       <NoRecordsTemplate>
                           <div style="padding: 8px 0 5px 5px; height: 20px; width: 110%;">
                               There are currently no candidates that match the selection.
                           </div>
                       </NoRecordsTemplate>
                       <Columns>
                           <telerik:GridTemplateColumn HeaderText="Candidate ID" UniqueName="CandidateID"      Visible="false">
                               <ItemTemplate>
                                   <%#Eval("CandidateID")%>
                               </ItemTemplate>
                           </telerik:GridTemplateColumn>
 
                           <telerik:GridTemplateColumn HeaderText="Prefix" HeaderStyle-Width="35px">
                               <ItemTemplate>
                                   <%#Eval("Prefix")%>
                               </ItemTemplate>
                           </telerik:GridTemplateColumn>
 
                           <telerik:GridTemplateColumn HeaderText="Forename">
                               <ItemTemplate>
                                   <%#Eval("Forename")%>
                               </ItemTemplate>
                           </telerik:GridTemplateColumn>
 
                           <telerik:GridTemplateColumn HeaderText="Surname">
                               <ItemTemplate>
                                   <%#Eval("Surname")%>
                               </ItemTemplate>
                           </telerik:GridTemplateColumn>
 
                           <telerik:GridTemplateColumn HeaderText="MobilePhone">
                               <ItemTemplate>
                                   <%#Eval("MobilePhone")%>
                               </ItemTemplate>
                           </telerik:GridTemplateColumn>
 
                       </Columns>
                   </MasterTableView>
                   <ClientSettings>
                       <Scrolling AllowScroll="True" UseStaticHeaders="True" SaveScrollPosition="true"></Scrolling>
                   </ClientSettings>
 
               </telerik:RadGrid>

 

Please ask if you need further information.

 

1 Answer, 1 is accepted

Sort by
0
IT
Top achievements
Rank 1
answered on 13 Jul 2017, 03:17 PM
I have resolved the problem. The RadGrid was wrapped in a  <asp:UpdatePanel> which was causing the paging to fail.
Tags
Ajax
Asked by
IT
Top achievements
Rank 1
Answers by
IT
Top achievements
Rank 1
Share this question
or