This is a migrated thread and some comments may be shown as answers.

RadGrid Item Command event is not fired upon dynamically assigning data source and columns.

1 Answer 54 Views
Grid
This is a migrated thread and some comments may be shown as answers.
MEHUL
Top achievements
Rank 1
MEHUL asked on 15 Dec 2008, 10:38 AM

Hi,

In one of my screen I am using Rad Grid and assigning the data source runtime. My data source is changing as per the different scenario. Hence i am not adding any columns at design time in the radgrid. Rather I have written a function which defines the columns and add it to the RadGrid column collection runtime only. I am calling this function (to add the columns) just before the assigning the data source Property to the RadGrid.

All these show my data in the grid perfectly fine.

But if I sort, or group, it doesn't call the event mapped (wired) and the columns headers are disappeared but the data in the grid perstists.

Kindly help me to get the solution if anyone of you has come across this sort of problem.

Thanks in advance.

Regards,
Mehul

 

1 Answer, 1 is accepted

Sort by
0
Yavor
Telerik team
answered on 17 Dec 2008, 09:33 AM
Hi MEHUL,

The following article contains more information on how to dynamically alter the control's structure, without breaking important functionalities.

Best wishes,
Yavor
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Tags
Grid
Asked by
MEHUL
Top achievements
Rank 1
Answers by
Yavor
Telerik team
Share this question
or