This is a migrated thread and some comments may be shown as answers.
RadGrid filter does not work fine
1 Answer 37 Views
This is a migrated thread and some comments may be shown as answers.
Carlos Castillo
Top achievements
Rank 1
Carlos Castillo asked on 29 Jul 2010, 04:52 PM

Hi, from Bogota, Colombia.

I am testing Telerik ASP.NET AJAX controls Version 2009.3.1103. I use RadGrid and I activate filters using a check box control.

The filter doesn't work fine if expression which filters a column has spaces; if such string is an only word, it works fine.

The column that I want to filter has a GridTemplateColumn template, which has 2 templates inside: An ItemTemplate and an EditItemTemplate. Is that related with this issue?

How can I solve it?

Thaks in advance for your answer.

Best Regards,



CARLOS ALBERTO CASTILLO
Bogota, Colombia.

1 Answer, 1 is accepted

Sort by
0
Pavlina
Telerik team
answered on 02 Aug 2010, 02:14 PM
Hello Carlos,

Please go through the following help articles, which elaborate on this subject and let me know if they help:
Operating with the FilterExpression of Telerik RadGrid manually
Implementing filtering for template/custom columns

Additionally, if the issue still persists, I will ask you to open a formal support ticket, and send us the problematic code, in the form of a working sample, for further investigation

Greetings,
Pavlina
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Tags
Grid
Asked by
Carlos Castillo
Top achievements
Rank 1
Answers by
Pavlina
Telerik team
Share this question
or