This is a migrated thread and some comments may be shown as answers.

RadEditor Template Manager

3 Answers 103 Views
Editor
This is a migrated thread and some comments may be shown as answers.
Meik Napierski
Top achievements
Rank 1
Meik Napierski asked on 17 Sep 2009, 03:35 PM
Hello,
i am evaluating the RadEditor control for ASP.NET AJAX with the last release. When I try to insert an template via the Template Manager, i receive an error message Access is denied. In Visual Studio i can see it happens in the function getResult : function() in the line return this._currentTemplateItem.contentWindow.document.body.innerHTML

the template is a normal HTML document whith a single word in the body element.

with best regards
Meik Napierski

 

 

3 Answers, 1 is accepted

Sort by
0
Rumen
Telerik team
answered on 18 Sep 2009, 03:12 PM
Hi Meik,

You can get this error only when the HTML document comes from another server, but it is not possible to configure the Template manager to load such a file. That is why to solve this odd problem my suggestion is to open a support ticket and send a sample working project that demonstrates the issue.

Best regards,
Rumen
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
0
Meik Napierski
Top achievements
Rank 1
answered on 21 Sep 2009, 04:35 PM
Hello,
i tried this with different formatted HTML documents. The documents came from a SharePoint List from the same server. The content of the template is always shown correctly in the preview but if i click on the insert button the Access denied error raises.

with best regards
Meik Napierski
0
Rumen
Telerik team
answered on 25 Sep 2009, 07:31 AM
Hi Meik,

The problem could be due to that your html template files contain links / script tags, the paths of which point to another domain and the browser throws "Access is denied" error when these tags are inserted in RadEditor's content area IFRAME element .

Could you please, open a support ticket and send us some of your HTML template files that are causing the error for examination? We will check them and find what is causing the problem after reproducing the problem.

Another reason for the issue could be that your site is running on HTTPS (SSL) and the files contains reference to other domains hosted on HTTP or vice versa.

Best regards,
Rumen
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
Tags
Editor
Asked by
Meik Napierski
Top achievements
Rank 1
Answers by
Rumen
Telerik team
Meik Napierski
Top achievements
Rank 1
Share this question
or