This is a migrated thread and some comments may be shown as answers.

Radeditor Image Manager Buttons Disabled

4 Answers 163 Views
Editor
This is a migrated thread and some comments may be shown as answers.
Scott Russell
Top achievements
Rank 1
Scott Russell asked on 10 Dec 2009, 09:32 PM
All of the buttons in my image manager are disabled and it doesntshow any of the images in the folder.  I have used the radeditor image manager several times before and never run into this issue before.  Any Ideas?


<telerik:RadEditor ID="txtContent" runat="server" 
    Width="100%"  
    Height="650px" 
    ImageManager-UploadPaths="~/img/"  
    ImageManager-ViewPaths="~/img/"  
    ImageManager-DeletePaths="~/img/" 
    ImageManager-EnableImageEditor="True"  
    ImageManager-MaxUploadFileSize="2097152"
</telerik:RadEditor> 



4 Answers, 1 is accepted

Sort by
0
Harry
Top achievements
Rank 1
answered on 11 Dec 2009, 06:23 AM
I got the same issue which happen to me on the pages under folder with form authentication, and it works find on the public pages whithout any authentication. Any ideas?

http://www.telerik.com/community/forums/aspnet-ajax/editor/radeditor-image-manager-upload-disabled.aspx
0
Scott Russell
Top achievements
Rank 1
answered on 11 Dec 2009, 01:34 PM
Now I am getting the following error when the image manager opens:

Sys.WebForms.PageRequestManager' is null or not an object
0
Rumen
Telerik team
answered on 14 Dec 2009, 06:32 PM
Hi guys,

Please, try the instructions in these articles:

Error: "Sys is not defined" in RadEditor dialogs,

Error: Web.config registration missing! The Telerik dialogs require a HttpHandler registration in the web.config file.

In form authentication scenario a non logged user is redirected to the login page. When a non user load some dialog then the code tried to load the login screen in the dialog, but the dialog expects other content and throws the reported error.

The DialogHandler must be always accessible and to fix the problem you should add the following two <location> entries to the web.config:

<location path="Telerik.Web.UI.DialogHandler.aspx">
    <system.web>
        <authorization>
            <allow roles="TestUser"/>
        </authorization>
    </system.web>
</location>
<location path="Telerik.Web.UI.SpellCheckHandler.axd">
    <system.web>
        <authorization>
            <allow roles="TestUser"/>
        </authorization>
    </system.web>
</location>


Kind regards,
Rumen
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
0
LEIDY JHOANA
Top achievements
Rank 1
answered on 21 May 2010, 04:59 PM
Hi this and try all possible solutions that give disabled yet still controls the image manager, the last thing you put
 <location path="Telerik.Web.UI.DialogHandler.aspx">
      <system.web>
        <authorization>
          <allow roles="TestUser"/>
        </authorization>
      </system.web>
    </location>
    <location path="Telerik.Web.UI.SpellCheckHandler.axd">
      <system.web>
        <authorization>
          <allow roles="TestUser"/>
        </authorization>
      </system.web>
    </location>
It does work, thanks ....
Tags
Editor
Asked by
Scott Russell
Top achievements
Rank 1
Answers by
Harry
Top achievements
Rank 1
Scott Russell
Top achievements
Rank 1
Rumen
Telerik team
LEIDY JHOANA
Top achievements
Rank 1
Share this question
or