RadControls on IIS 7

Thread is closed for posting
3 posts, 1 answers
  1. Fabian Gehri
    Fabian Gehri avatar
    10 posts
    Member since:
    Feb 2010

    Posted 24 Feb 2010 Link to this post

    Hi there,

    I'm trying to get the RadScheduler to work in an ASP.NET MVC 2 project running locally on IIS 7 Integrated Mode (on Windows Vista).

    But I'm always getting this (famous) error message:

    "The WebResource.axd handler must be registered in the configuration to process this request

    <!-- Web.Config Configuration File -->

               <add path="WebResource.axd" verb="GET" type="System.Web.Handlers.AssemblyResourceLoader" validate="True" />

    I went through all the troubleshooting topics in the documentation and lots of threads in this forum and checked my web.config entrys a thousand times. Still the same problem. This is the part of my web.config relevant for IIS 7 (Integrated Mode):

          <remove name="WebServiceHandlerFactory-Integrated" /> 
          <remove name="ScriptHandlerFactory" /> 
          <remove name="ScriptHandlerFactoryAppServices" /> 
          <remove name="ScriptResource" /> 
          <remove name="MvcHttpHandler" /> 
          <remove name="UrlRoutingHandler" /> 
          <!--<add name="Telerik_Web_UI_WebResource" verb="*" path="Telerik.Web.UI.WebResource.axd" preCondition="integratedMode" type="Telerik.Web.UI.WebResource, Telerik.Web.UI, Version=2009.3.1314.35, Culture=neutral, PublicKeyToken=121fae78165ba3d4"/>--> 
          <add name="Telerik_Web_UI_WebResource" verb="*" path="Telerik.Web.UI.WebResource.axd" preCondition="integratedMode" type="Telerik.Web.UI.WebResource" /> 
          <add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=, Culture=neutral, PublicKeyToken=31BF3856AD364E35" /> 
          <add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=, Culture=neutral, PublicKeyToken=31BF3856AD364E35" /> 
          <add name="ScriptResource" preCondition="integratedMode" verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=, Culture=neutral, PublicKeyToken=31BF3856AD364E35" /> 
          <add name="MvcHttpHandler" preCondition="integratedMode" verb="*" path="*.mvc" type="System.Web.Mvc.MvcHttpHandler, System.Web.Mvc, Version=, Culture=neutral, PublicKeyToken=31BF3856AD364E35" /> 
          <add name="UrlRoutingHandler" preCondition="integratedMode" verb="*" path="UrlRouting.axd" type="System.Web.HttpForbiddenHandler, System.Web, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" /> 

    It doesn't work for both the commented and uncommented "Telerik_Web_UI_WebResource" line.

    If I run my project on the VS Development Server it works perfectly.

    The error only arises in Views where I have the RadScheduler (or another RadControl). Here's a View which gives an error:

    <%@ Page Title="" Language="C#" MasterPageFile="~/Views/Shared/Coach.Master" Inherits="System.Web.Mvc.ViewPage" %> 
    <%@ Register Assembly="Telerik.Web.UI" Namespace="Telerik.Web.UI" TagPrefix="telerik" %> 
    <asp:Content ID="Content1" ContentPlaceHolderID="TitleContent" runat="server"
    <asp:Content ID="Content2" ContentPlaceHolderID="MainContent" runat="server"
        <telerik:RadScheduler ID="CoachScheduler" runat="server" ProviderName="CoachSchedulerProvider"
        <telerik:RadScriptManager ID="RadScriptManager1" runat="server"

    I even tried the demo attached here, but I get the same error when running on IIS 7, but not on Development Server.

    My conclusion was that either something is wrong in the configuration of IIS 7 or the error arises from the fact that the URLs are different on IIS 7 (e.g. "http://localhost:50000/..." on Development Server but "http://localhost/MvcApplication/..." on IIS).

    I can see all the handlers registered in the above web.config section in the handlers list in IIS, so I don't think I've done anything wrong here..

    Thanks in advance.
  2. Answer
    Atanas Korchev
    Atanas Korchev avatar
    8462 posts

    Posted 24 Feb 2010 Link to this post

    Hello Fabian Gehri,

    The exception says that WebResource.axd is not registered not Telerik.Web.UI.WebResource.axd. This file is the standard ASP.NET WebResource HTTP handler and should be registered always.

    I suggest you check this forum thread which discusses a similar problem.

    Best wishes,
    Atanas Korchev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. Fabian Gehri
    Fabian Gehri avatar
    10 posts
    Member since:
    Feb 2010

    Posted 24 Feb 2010 Link to this post

    Hi Atanas,

    thanks a lot for your answer!

    Of course you're right that the exception is about the WebResource.axd and not the Telerik one. My fault I forgot to tell you that I already tried that before, but since it did not work deleted it again:

    <add name="WebResource_axd" path="WebResource.axd" verb="GET" type="System.Web.Handlers.AssemblyResourceLoader" /> 

    I thought it was not needed since there is a handler (named "AssemblyResourceLoader-Integrated" and of type "System.Web.Handlers.AssemblyResourceLoader") in IIS on server level. The web.config entry is also not present in the demo I mentioned above neither in <system.web><httpHandlers> nor <system.webServer><handlers>.)

    I tried again adding this handler to my web.config and as expected it still did not work.

    But I found the solution to my problem in the thread of the link you posted: I am running ColdFusion 8 in the same application pool as ASP.NET and the wildcard handler needed for CF is registered. According to the discussion in another forum thread it should be fixed in .Net Framework 3.5 SP1 but obviously is not since I get the error with SP1 being installed and also others are reporting same problems.

    Anyway, after I removed the wildcard handler (named "AboMapperCustom-1169055" and pointing to "C:\ColdFusion8\runtime\lib\wsconfig\1\jrun_iis6_wildcard.dll" in my case) the RadScheduler Control now appears without any errors!

    And you were totally right, the web.config entry for the WebResource.axd handler is really needed. Without it I get the same exception again..

    I guess the ColdFusion applications won't work now that I removed the wildcard handler, so I will try to separate ColdFusion and ASP.NET applications tomorrow..

    Thanks again for your great answer!

    Cheers, Fabian

Back to Top