RadComboBox throwing "that assembly does not allow partially trusted callers" after upgrading webpart to SP2013

2 posts, 0 answers
  1. John
    John avatar
    14 posts
    Member since:
    Jun 2013

    Posted 09 Jun 2013 Link to this post

    Hi,

    I have recently updated a webpart which worked in SP2010 to SP2013, the upgrade process was changing the target framework and referencing the telerik.ui for 4.5

    After deploying the webpart into SP2013, i'm now getting this error:

    "that assembly does not allow partially trusted callers"

    I assume its to do with the changes in 4.5 security? has anyone experienced the same issue?

    I'd like to avoid putting the telerik.dll's in the GAC

    Thanks
  2. Nencho
    Admin
    Nencho avatar
    1812 posts

    Posted 13 Jun 2013 Link to this post

    Hello John,

    Please refer to this forum thread, where this exception is discussed in details :
    http://stackoverflow.com/questions/4314420/that-assembly-does-not-allow-partially-trusted-callers-initializecomponent

    Hope this would help.

    Regards,
    Nencho
    Telerik
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
Back to Top