Prometheus and WSS 3.0 (SharePoint 2007), how to make .wsp install packet

3 posts, 0 answers
  1. Sakari Hilama
    Sakari Hilama avatar
    6 posts
    Member since:
    Aug 2007

    Posted 23 Jan 2008 Link to this post


    I have been trying to make .wsp install package from newest RadControls Prometheus. I did make working .wsp package from RadControls for using whitepaper and now I have been trying to make that package with new Prometheus dll's, but no luck. I am not sure what namespaces I should register as safe components and what dll's or other files I need to put into that .wsp package.

    Could anyone that has made this .wsp, list out briefly what files and namespaces did you register into that manifest.xml and listed in ddf file ?

    I tried following very basic scenario: I took telerik.web.ui.dll (that approx. 9 mb dll file from bin35), listed it in ddf file and registered telerik.web.ui namespace as safecontrol. Deployment works perfectly but when I try to add a web part into WSS 3.0 site, error comes up saying something about missing files (which means that .wsp lacks some needed files, I know that if I turn debug mode on, I get more sophisticated information about error but at this moment I can not turn that debugging on).

    I need to admit that I could get this working if I could get that debug mode on but at this moment time is not on my side :(

    Many thanks in advance to anyone that can give advices to this "problem".
  2. Lini
    Lini avatar
    2144 posts

    Posted 23 Jan 2008 Link to this post


    The namespace you should register is "Telerik.Web.UI". I think that you only need the Telerik.Web.UI.dll assembly in the WSP file. The new Prometheus controls do not have a RadControls folder since all skins and scripts are embedded in the assembly.

    I think that WSS 3.0 is running on .NET 3.0 so you cannot use the assembly from the bin35 folder, because it is compiled against .NET 3.5. You will need the Telerik.Web.UI.dll assembly from the bin folder. In addition you need to make sure that ASP.NET Ajax 1.0 is installed on the server as well.

    If you are trying to use the editor or spell controls, then you will also need to pack the App_Data folder since it contains the dictionaries for the spellchecker.

    All the best,
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. Sakari Hilama
    Sakari Hilama avatar
    6 posts
    Member since:
    Aug 2007

    Posted 24 Jan 2008 Link to this post

    Thank you to this quick answer.

    So I was on the right tracks in that case but still I get some kind of file missing error. I am doing now a research why debug mode refuses to work the way it should be in order to get missing file name (basically when I turn that debug mode on by switching web.config files I get access denied on that web.config file that has been edited or in MOSS I get some other errors before I could load main page of MOSS). I installed that ajax 1.0 packet but still no luck (I also checked that assemblies are in right places).

    I think that if these problems do continue I should open support ticket for this matter since this looks much like "only me problem".
Back to Top